Bug 146070 - Printing in Asian layout mode is incorrect in Calc
Summary: Printing in Asian layout mode is incorrect in Calc
Status: RESOLVED DUPLICATE of bug 144378
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.3.0.0 alpha0+
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-06 03:01 UTC by Junichi Matsukawa
Modified: 2021-12-06 10:50 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
PDF printed with 'Microsoft Print to PDF'. (13.08 MB, application/pdf)
2021-12-06 04:14 UTC, Junichi Matsukawa
Details
I will attach a sample file. (8.87 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-12-06 04:15 UTC, Junichi Matsukawa
Details
Comparison of sample display and PDF display. (100.80 KB, image/png)
2021-12-06 04:33 UTC, Junichi Matsukawa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Junichi Matsukawa 2021-12-06 03:01:25 UTC
Description:
Printing in Asian layout mode is incorrect in Calc. 'Cube PDF' doesn't print correctly either. 'Export Directry as PDF Icon' will output PDF correctly.

Steps to Reproduce:
1.Enter characters in cells in Chinese characters (double-byte)
2.Select Vatically stacked, Asian layout mode in Text Orientation in the cell formatting
3.Print to Microsoft print to PDF

Actual Results:
Character printing is off by 90 degrees

Expected Results:
Character printing is off by 90 degrees


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
7.2 has similar defects
Comment 1 Junichi Matsukawa 2021-12-06 04:14:34 UTC
Created attachment 176720 [details]
PDF printed with 'Microsoft Print to PDF'.

PDF printed with 'Microsoft Print to PDF'.

Version: 7.3.0.0.beta1+ (x64) / LibreOffice Community
Build ID: 8c137ff0e201c2d0ecd1bb567496dbed8e5eced7
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: default; VCL: win
Locale: ja-JP (ja_JP); UI: en-GB
Calc: CL
Comment 2 Junichi Matsukawa 2021-12-06 04:15:29 UTC
Created attachment 176721 [details]
I will attach a sample file.

I will attach a sample file.
Comment 3 Junichi Matsukawa 2021-12-06 04:33:48 UTC
Created attachment 176722 [details]
Comparison of sample display and PDF display.

Comparison of sample display and PDF display.
Comment 4 Ming Hua 2021-12-06 10:50:30 UTC
Thanks for reporting.  This looks like the same issue as in bug 144378, so I'm marking as a DUPLICATE.

*** This bug has been marked as a duplicate of bug 144378 ***