Bug 146097 - RED CROSS -- search toolbar close button's RED color is ambiguous
Summary: RED CROSS -- search toolbar close button's RED color is ambiguous
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.2.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Find-Toolbar
  Show dependency treegraph
 
Reported: 2021-12-07 14:17 UTC by peter josvai
Modified: 2022-01-13 13:14 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
LibreOffice close button on the far right (47.13 KB, image/png)
2022-01-07 09:31 UTC, Rizal Muttaqin
Details
Firefox search bar has close icon in the right. (9.34 KB, image/png)
2022-01-07 09:33 UTC, Rizal Muttaqin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description peter josvai 2021-12-07 14:17:33 UTC
hi, 


when going: CTRL+f the find toolbar appears at the bottom (or wherever)

left to the search field there is a close button...

a big extremely visible X in the middle of it
(low target intelligence)

the problem is that this "red circle", more precisely, that this circle is red...

cause we are accustomed to see red color there when (after hitting enter to search), there is zero result...

sure, the two things are different...
this red circle is for closing the bar which, let's admit, can be great annoyance if you don't know how to close it -- make it just disappear :)

suggestion: keep it in normal color, like the X in the top right corner of the windows..

I KNOW, this is a question about icon sets..
but -- if you find this critique relevant -- you could make sure it would not be "red"... it could also be smaller...

:::::::::::
NOTE:

a tendency can be observed by now to make libreoffice easy to use for even superficial people who are in  non-intelligent mode
(which happens to most of us time to time)

I think this is a bad idea... a bad concept..

sure, if MS indulges people in dumb mode, they'll choose MSO, not LIO...
but the interface can be made intuitive, as it already is, pretty much, and that's should be the goal, I believe... not the dumb and super dumb mode :)

this red cross, as a matter of fact, appears to be serving the super dumb mode people :) 



🟊 🟊 🟊 thank you for developing Libreoffice 🟊 🟊 🟊
Comment 1 peter josvai 2021-12-07 14:27:22 UTC
I forgot to say: it is like an error message...
Comment 2 Dieter 2021-12-22 07:32:57 UTC
Let's decide design-team. Personally i won't follow you suggestion, because we have the same red cross in 
File -> Close
and in every close-icon in the toolbar
Changing this in find-toolbar would be inconsistent
Comment 3 Heiko Tietze 2022-01-04 09:51:43 UTC
All shipped icon themes except Sifr show a red cross, and except Sukapura with a red background. Searching the Internet for images with symbol size using the term "close" returns more or less the same: red crosses.

Rizal, Andreas: What do you think?
Comment 4 Rizal Muttaqin 2022-01-07 09:31:56 UTC
Created attachment 177366 [details]
LibreOffice close button on the far right

(In reply to Heiko Tietze from comment #3)
> All shipped icon themes except Sifr show a red cross, and except Sukapura
> with a red background. Searching the Internet for images with symbol size
> using the term "close" returns more or less the same: red crosses.
> 
> Rizal, Andreas: What do you think?

For the sake of consistency, I prefer to keep it red as it as stated by Dieter in #c2. But I am agree that the close button position is a little bit weird. Let have take a look at how current Firefox's search bar is implemented. The close icon is on the far right end of the toolbar. This brings consistency with close button when opening a module in LibreOffice (opening multiple files or multiple Libo modules make the close button disappear

Another option may be if user want to get rid off the red color is to use non icon based image just like the close button I attach here.
Comment 5 Rizal Muttaqin 2022-01-07 09:33:38 UTC
Created attachment 177367 [details]
Firefox search bar has close icon in the right.

I must admit Firefox make use more neutral color here but remember their icon theme is also monochrome.
Comment 6 Rizal Muttaqin 2022-01-07 09:37:21 UTC
(In reply to peter josvai from comment #0)


> I KNOW, this is a question about icon sets..
> but -- if you find this critique relevant -- you could make sure it would
> not be "red"... it could also be smaller...

Each icon has same image size with another with other so in current state if you want to make it smaller just use small icon theme.
Comment 7 V Stuart Foote 2022-01-11 14:27:31 UTC
As with Dieter and Rizal we use the same Red motif elsewhere so -1 for consistency across the icons themes.

Position is appropriate to the Find Bar, in fact if you unlock the TB and drag it out to float--it has the os/DE close button in the frames CSD. Let's not move the button.
Comment 8 Heiko Tietze 2022-01-13 13:14:32 UTC
The topic was on the agenda of the design meeting. There is a clear rejection of the proposal, although Rizal might consider in the future to revise the strong red color. For now it's a WF.