Bug 146108 - Calc is slow to change cell focus in a document with a big background image
Summary: Calc is slow to change cell focus in a document with a big background image
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.0.0.alpha0+
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.4.0 target:7.3.0.0.beta2 tar...
Keywords: bibisected, bisected, perf, regression
Depends on:
Blocks:
 
Reported: 2021-12-08 01:09 UTC by Michael
Modified: 2021-12-11 16:18 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A spreadsheet with the problem. Go to the log page and move around just by clicking cells. (3.74 MB, application/vnd.oasis.opendocument.spreadsheet)
2021-12-08 01:09 UTC, Michael
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2021-12-08 01:09:12 UTC
Created attachment 176781 [details]
A spreadsheet with the problem. Go to the log page and move around just by clicking cells.

First of all, it's version 7.1.8.1. 

Version: 7.1.8.1 (x64) / LibreOffice Community
Build ID: e1f30c802c3269a1d052614453f260e49458c82c
CPU threads: 2; OS: Windows 10.0 Build 19044; UI render: default; VCL: win
Locale: en-CA (en_CA); UI: en-US
Calc: threaded

My Windows 10 is up-to-date with the absolute latest version.

Edition	Windows 10 Home
Version	21H2
Installed on	‎2020-‎11-‎26
OS build	19044.1348
Experience	Windows Feature Experience Pack 120.2212.3920.0

Device name	AZC
Processor	Intel(R) Pentium(R) CPU 2127U @ 1.90GHz   1.90 GHz
Installed RAM	8.00 GB (7.89 GB usable)
Device ID	
Product ID	00326-10000-00000-AA422
System type	64-bit operating system, x64-based processor

I saw the report about a security update to Libre Office and was urged to update to 7.1.8.1. I had been on version 6.3.5.2 with no problems. Calc in version 7.1.8.1 was VERY slow. Just clicking on another cell took 3 to 4 seconds before the new cell was activated. I uninstalled 7.1.8.1 and re-installed 6.3.5.2. The Ask LibreOffice forum suggested I change my %APPDATA%...\user to user_old and start 6.3.5.2 so a new user profile would be created. I did that. I reinstalled 7.1.8.1 again, but I had the same problem. I turned off Skia and anti-aliasing, but nothing changed. I also re-started in Safe mode, but the response was still very slow. One of our other users tested a spreadsheet on his Windows 10, and he had the same very slow response.
Comment 1 Buovjaga 2021-12-08 08:56:59 UTC
Bibisected with linux-64-7.1 to https://git.libreoffice.org/core/commit/57c40329a2b469813a1f357de355a37c8e3077ae
tdf#136058: remove some caching

Adding Cc: to Noel Grandin
Comment 2 Commit Notification 2021-12-08 10:47:50 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/829510594b394d00ca2b4acb0ed64c6bda0f311c

tdf#146108 Calc slow to change cell focus..

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2021-12-10 11:10:00 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/585bf5f2b223a1449dd8f6b65c5f0c0c00160af7

tdf#146108 Calc slow to change cell focus..

It will be available in 7.3.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2021-12-10 21:54:00 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/26259e4089ec0225e84ed99159d85e858f612022

tdf#146108 Calc slow to change cell focus..

It will be available in 7.2.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Michael 2021-12-11 01:34:04 UTC
I just installed 7.2.5.0.0 and ran a test on my file. It is still very slow to change focus: 3-4 seconds. You will notice, on the setup page of the spreadsheet I uploaded, that there is an Enhance Image option. If this is set to Yes, the focus is very slow. Otherwise, it is normal. There are times that the images are so faint that the Enhance Image option needs to be selected. You may have to click the Get Image button on the Log Page so the image will be enhanced.
Comment 6 Buovjaga 2021-12-11 09:47:21 UTC
(In reply to Michael from comment #5)
> I just installed 7.2.5.0.0 and ran a test on my file. It is still very slow
> to change focus: 3-4 seconds. You will notice, on the setup page of the
> spreadsheet I uploaded, that there is an Enhance Image option. If this is
> set to Yes, the focus is very slow. Otherwise, it is normal. There are times
> that the images are so faint that the Enhance Image option needs to be
> selected. You may have to click the Get Image button on the Log Page so the
> image will be enhanced.

Looking at the latest available daily libreoffice-7-2 build, the backported commit is not yet in it. Please just test a master build Win-x86_64@tb77-TDF https://dev-builds.libreoffice.org/daily/master/current.html

The problem is gone for me in

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 29db6dc9fbeb8314553d02a9519a4cb8161256f4
CPU threads: 2; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: fi-FI (fi_FI); UI: en-US
Calc: threaded
Comment 7 Michael 2021-12-11 16:11:48 UTC
I tested my spreadsheet with the correct version, and the slow focus problem is indeed fixed!

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 29db6dc9fbeb8314553d02a9519a4cb8161256f4
CPU threads: 2; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: fi-FI (fi_FI); UI: en-US
Calc: threaded