Bug 146174 - ALT no longer usable for hotkeys, goes to dropdown menu now (started in 7.2.3) (gtk3 only)
Summary: ALT no longer usable for hotkeys, goes to dropdown menu now (started in 7.2.3...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.3.1.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.4.0 target:7.3.3 target:7.2.7
Keywords:
: 146739 147253 147341 147434 148258 (view as bug list)
Depends on:
Blocks: Customize-Dialog-Keyboard Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2021-12-11 09:00 UTC by jojobader
Modified: 2022-10-06 13:53 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jojobader 2021-12-11 09:00:45 UTC
Description:
Starting in 7.2.3 i can no longer use key-combinations that involve the ALT key because they get caught by the dropdown menu... this was not the case in 7.2.2 and is at least for me a big hurdle now, which renders LO almost useless ...

Steps to Reproduce:
1. Assign an action (for example "Delete to Start of Line") to Alt+i in the "Tools" > "Customize" > "Keyboard" window
2. Try to use that key
3. See that it opens the dropdown menu for "Insert" instead ...

Actual Results:
drop down menu gets preferred to custom key-combinations ...

Expected Results:
I expected that i can use the ALT key for all keys, not just the ones that are "free" from having a drop-down menu key attached ...


Reproducible: Always


User Profile Reset: Yes



Additional Info:
...
Comment 1 jojobader 2021-12-14 14:27:50 UTC
This person has the same problem

https://old.reddit.com/r/i3wm/comments/rg7w7d/how_do_disable_alt_keys_in_programs/

(because i don't know how this system here works, i'll try to set this to confirmed (is that NEW?), seeing this is a severe change in the programs behaviour)
Comment 2 Michael Warner 2021-12-15 13:07:10 UTC
(In reply to jojobader from comment #1)

> (because i don't know how this system here works, i'll try to set this to
> confirmed (is that NEW?), seeing this is a severe change in the programs
> behaviour)

The way it works is that it should remain UNCONFIRMED until someone other than the reporter can replicate the issue and confirm that it is a bug. If that happens, then that person will set it to NEW.

It would be helpful if you include the version information from Help->"About LibreOffice".

Looking through recent commits I found this one, but I do not know if it is related to this report:

https://gerrit.libreoffice.org/c/core/+/122926
Comment 3 jojobader 2021-12-19 15:03:48 UTC
(In reply to Michael Warner from comment #2)
> (In reply to jojobader from comment #1)
> 
> > (because i don't know how this system here works, i'll try to set this to
> > confirmed (is that NEW?), seeing this is a severe change in the programs
> > behaviour)
> 
> The way it works is that it should remain UNCONFIRMED until someone other
> than the reporter can replicate the issue and confirm that it is a bug. If
> that happens, then that person will set it to NEW.
> 
> It would be helpful if you include the version information from Help->"About
> LibreOffice".
> 
> Looking through recent commits I found this one, but I do not know if it is
> related to this report:
> 
> https://gerrit.libreoffice.org/c/core/+/122926

Thanks Michael! Sorry, i can't report the exact version anymore (apart from the exact version number), the bug was so severe for me that I went back to using LibreOffice Still, where this hasn't spread to yet ...
Comment 4 Stang 2022-01-15 21:46:36 UTC
Verified this did work in:

Version: 7.2.2.2 / LibreOffice Community
Build ID: 02b2acce88a210515b4a5bb2e46cbfb63fe97d56
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 5 Paul Janzen 2022-01-15 22:35:37 UTC
I also confirm that it is working like the title says. Hotkeys with ALT not usable anymore. But it is a bug and it should be fixed, because I use a lot of shortcut keys, and Alt+(letter) are among them.

Linux Mint 20.3
Version: 7.2.5.2 / LibreOffice Community
Build ID: 20(Build:2)
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: es-PY (en_US.UTF-8); UI: en-US
Ubuntu package version: 1:7.2.5~rc2-0ubuntu0.20.04.1~lo1
Calc: threaded
Comment 6 jojobader 2022-02-05 14:28:56 UTC
I had switched to the "still" branch of LO because of this bug, but today this bug made it there aswell and is now in the most "stable" branch of LO ...

All i can do is reply to this again, so maybe it gets recognized when other confirm it ...
Comment 7 jojobader 2022-02-05 14:29:59 UTC
(In reply to jojobader from comment #6)
> I had switched to the "still" branch of LO because of this bug, but today
> this bug made it there aswell and is now in the most "stable" branch of LO
> ...
> 
> All i can do is reply to this again, so maybe it gets recognized when other
> confirm it ...

Sorry here is the current version that is suffering from this bug:

Version: 7.2.5.2.0+ / LibreOffice Community
Build ID: 20(Build:2)
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: de-DE (en_US.utf8); UI: en-US
7.2.5-2
Calc: threaded
Comment 8 freenas.kurt 2022-02-06 23:46:32 UTC
The bug also appears in

Linux Mint 20.3
Version: 7.3.0.3 / LibreOffice Community
Build ID: 0f246aa12d0eee4a0f7adcefbf7c878fc2238db3
CPU threads: 2; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: de-DE (de_DE.UTF-8); UI: de-DE
Calc: threaded

I use my hotkeys ALT+F, ALT+H etc all day, so I cannot work anymore since updating from 7.2.0 ...

Seems to be a problem with gtk3 only. If I do:
  export SAL_USE_VCLPLUGIN=qt5
or
  export SAL_USE_VCLPLUGIN=gen
and start LO from command line, the hotkeys work. (They also work in LO for Windows)

So Michael's connection with the recent commit to gtk3 menubar might be correct?
Comment 9 jojobader 2022-02-09 12:04:33 UTC
(In reply to freenas.kurt from comment #8)
> The bug also appears in
> 
> Linux Mint 20.3
> Version: 7.3.0.3 / LibreOffice Community
> Build ID: 0f246aa12d0eee4a0f7adcefbf7c878fc2238db3
> CPU threads: 2; OS: Linux 5.4; UI render: default; VCL: gtk3
> Locale: de-DE (de_DE.UTF-8); UI: de-DE
> Calc: threaded
> 
> I use my hotkeys ALT+F, ALT+H etc all day, so I cannot work anymore since
> updating from 7.2.0 ...
> 
> Seems to be a problem with gtk3 only. If I do:
>   export SAL_USE_VCLPLUGIN=qt5
> or
>   export SAL_USE_VCLPLUGIN=gen
> and start LO from command line, the hotkeys work. (They also work in LO for
> Windows)

This workaround doesn't work for me, probably because I don't have some of the underlying infrastructure.
Comment 10 freenas.kurt 2022-02-09 20:32:09 UTC
That is possible - I use the AppImage from www.libreoffice.org/download/appimage, I do not have a *.deb or distribution package of LO installed.

Just to be sure:
Did you open a shell as normal user and enter

export SAL_USE_VCLPLUGIN=gen

and then from the same shell start LibreOffice with (I have to guess for your system)

PATH/TO/YOUR/soffice.bin or PATH/TO/YOUR/swriter
Comment 11 Michael Warner 2022-02-19 14:08:14 UTC
*** Bug 147341 has been marked as a duplicate of this bug. ***
Comment 12 Michael Warner 2022-02-19 14:10:08 UTC
*** Bug 147434 has been marked as a duplicate of this bug. ***
Comment 13 Michael Warner 2022-02-19 14:16:46 UTC
*** Bug 147253 has been marked as a duplicate of this bug. ***
Comment 14 Frank Steiner 2022-03-01 13:07:00 UTC
Same here, and it really sucks, because we have a bunch of macros defined that our users are used to execute by shortcuts with the Alt key. "export SAL_USE_VCLPLUGIN=gen" does help, but we want to use the GTK interface for several reasons. So, this really should be fixed if possible...
Comment 15 freenas.kurt 2022-03-12 23:14:28 UTC
Still the same in LibreOffice 7.3.1 - please fix it, people cannot use shortcuts with ALT.

Maybe the bug was introduced, because a user complained he could not activate the dropdown menu with ALT (and then e.g. "Format" with F).

But like in LibreOffice for Windows and MS Word the menu bar should react on Push ALT + Release ALT, whereas Push ALT + F starts the defined shortcut.
Comment 16 Paolo Aranha 2022-03-27 15:43:39 UTC
I can confirm that the bug occurs also on Libreoffice 7.3.

As a consequence, the default keyboard binding Alt+F, meant to insert Footnotes in Libreoffice Writer, doesn't work anymore.

This binding is clearly shown as a default setting under the menu Customize -> Keyboard, but then Alt+F doesn't insert a Footnote, but rather calls the "File" Menus, just as Alt+E calls the "Edit" menu etc.
However, as a further inconsistency within a very annoying inconsistency of its own, Alt+S doesn't call the "Styles" menu, which is activated only by F11.

I kindly request the developer to consider this as a real bug: if Libreoffice settings promise a certain behavior (i.e. Alt+F inserting footnotes), but then does something else in reality, there is a problem. 

I am strongly affected in my productivity by this bug.
Comment 17 V Stuart Foote 2022-03-30 12:37:32 UTC
(In reply to Paolo Aranha from comment #16)
> I can confirm that the bug occurs also on Libreoffice 7.3.
> 
> As a consequence, the default keyboard binding Alt+F, meant to insert
> Footnotes in Libreoffice Writer, doesn't work anymore.
> 
> This binding is clearly shown as a default setting under the menu Customize
> -> Keyboard, but then Alt+F doesn't insert a Footnote, but rather calls the
> "File" Menus, just as Alt+E calls the "Edit" menu etc.
> However, as a further inconsistency within a very annoying inconsistency of
> its own, Alt+S doesn't call the "Styles" menu, which is activated only by
> F11.
> 
> I kindly request the developer to consider this as a real bug: if
> Libreoffice settings promise a certain behavior (i.e. Alt+F inserting
> footnotes), but then does something else in reality, there is a problem. 
> 

Those are not TDF "default" key bindings. The command .uno:InsertFootnote has no Keyboard short-cut assigned by default.  The .uno:DesignerDialog is *only* assigned the <F11> short-cut. If the shortcuts show defined (in the Customize dialog) it was done in profile, or by your package builder.  Clear your profile, or replace your package with a TDF build.
Comment 18 V Stuart Foote 2022-03-30 12:43:04 UTC
Modified gtk3 behavior as noted in see also bug 148258 with https://gerrit.libreoffice.org/c/core/+/122926 that addressed bug 144846
Comment 19 Caolán McNamara 2022-04-05 07:45:15 UTC
*** Bug 146739 has been marked as a duplicate of this bug. ***
Comment 20 Caolán McNamara 2022-04-05 16:04:06 UTC
the easiest thing to do is to probably revert back to the original state, there will be an inconsistency but the original state was apparently less of a problem than the current one
Comment 21 Caolán McNamara 2022-04-05 16:07:28 UTC
on the other hand bug 148258 has a patch which looks promising

*** This bug has been marked as a duplicate of bug 148258 ***
Comment 22 Commit Notification 2022-04-06 08:44:23 UTC
Vincent Reher committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2703f729e9ea0bbc1f64b04b535a676a2980e1b8

Resolves: tdf#146174 allow shortcut key event handling before menubar

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 23 Caolán McNamara 2022-04-06 09:07:47 UTC
backports to 7-3 and 7-2 in gerrit
Comment 24 Commit Notification 2022-04-06 11:53:12 UTC
Vincent Reher committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/38c40316289cf78decb6b5e4b93f50ffcfe7bd52

Resolves: tdf#146174 allow shortcut key event handling before menubar

It will be available in 7.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 25 Vince 2022-04-06 19:06:13 UTC
*** Bug 148258 has been marked as a duplicate of this bug. ***
Comment 26 Commit Notification 2022-04-07 06:27:30 UTC
Vincent Reher committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/41c00d9cf065a6b5ba676807b446f32426e5d642

Resolves: tdf#146174 allow shortcut key event handling before menubar

It will be available in 7.2.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 27 Jean-Baptiste Faure 2022-04-07 11:54:47 UTC
Verified fixed in Version: 7.3.3.0.0+ / LibreOffice Community
Build ID: f02673722dc14c9f1864887d5b159cda0d7ae8c4
CPU threads: 8; OS: Linux 5.13; UI render: default; VCL: gtk3
Locale: fr-FR (fr_FR.UTF-8); UI: fr-FR
Ubuntu_20.04_x86-64
Calc: threaded

Thank you very much.

Best regards. JBF
Comment 28 James Smith 2022-04-11 22:17:13 UTC
(In reply to Jean-Baptiste Faure from comment #27)
> Verified fixed in Version: 7.3.3.0.0+ / LibreOffice Community
> Build ID: f02673722dc14c9f1864887d5b159cda0d7ae8c4
> CPU threads: 8; OS: Linux 5.13; UI render: default; VCL: gtk3
> Locale: fr-FR (fr_FR.UTF-8); UI: fr-FR
> Ubuntu_20.04_x86-64
> Calc: threaded
> 
> Thank you very much.
> 
> Best regards. JBF

Did it work on fresh install?

I'm on:
Version: 7.3.2.2 / LibreOffice Community
Build ID: 49f2b1bff42cfccbd8f788c8dc32c1c309559be0
CPU threads: 4; OS: Linux 5.13; UI render: default; VCL: gtk3
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded

and still having the issue :/
Comment 29 James Smith 2022-04-11 22:21:44 UTC Comment hidden (me-too)
Comment 30 V Stuart Foote 2022-04-11 22:31:37 UTC
See the BZ Whiteboard target notations. This has been adjusted for the 7.3.3 build, not present in 7.3.2

Work against a nightly of master against 7.4.0 or the 7.3.3 build

https://dev-builds.libreoffice.org/daily/libreoffice-7-3/Linux-rpm_deb-x86_64@tb87-TDF/

https://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@tb87-TDF/
Comment 31 aystic 2022-04-14 06:01:32 UTC
Version: 7.3.3.1 / LibreOffice Community
Build ID: 1688991ca59a3ca1c74bc2176b274fba1b034928
CPU threads: 8; OS: Linux 5.16; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

Thank you very much for resolving the issue!