Bug 146181 - Visual glitches for theme personalization when more than two toolbars docked at the bottom
Summary: Visual glitches for theme personalization when more than two toolbars docked ...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.6.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: 125217
Blocks: LibreOffice-Themes
  Show dependency treegraph
 
Reported: 2021-12-11 14:11 UTC by lol
Modified: 2021-12-12 18:56 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
3 toolbars opened (104.36 KB, image/png)
2021-12-11 14:11 UTC, lol
Details
4 toolbars opened (71.26 KB, image/png)
2021-12-11 14:14 UTC, lol
Details
Default look (130.83 KB, image/png)
2021-12-12 18:39 UTC, lol
Details
Dark theme (139.44 KB, image/png)
2021-12-12 18:43 UTC, lol
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lol 2021-12-11 14:11:25 UTC
Created attachment 176869 [details]
3 toolbars opened

If you have more than two toolbars open which are docked at the bottom, the UI in Writer breaks (see pictures).
Comment 1 lol 2021-12-11 14:14:15 UTC
Created attachment 176870 [details]
4 toolbars opened
Comment 2 Rainer Bielefeld Retired 2021-12-11 15:15:47 UTC
NOT reproducible with Server Installation of Version 7.3.0.0.alpha1+ (x64)  |   Build ID b8d17d754830ab57099dcdfa72a96bfad404ab1a  |  CPU threads: 12; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win  |  Locale: de-DE (de_DE); UI: de-DE  |  Calc: CL  |  Special devUserProfileL  |  Colibri Theme 

@reporter:
a) did you already test with a newly created user profile?
b) your OS is WIN10?
Comment 3 V Stuart Foote 2021-12-12 01:02:53 UTC
Also can not confirm on Windows 10 with Skia Vulkan or Skia software rendered raster UI.

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 7e5af164b7d293dd410710bed411e1ca64bbecf7
CPU threads: 8; OS: Windows 10.0 Build 19044; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded

Please provide build and os/DE details
Comment 4 Telesto 2021-12-12 10:16:15 UTC
Have you test with a clean profile? Menu/Help/Restart in Safe Mode
Comment 5 lol 2021-12-12 11:07:22 UTC
(In reply to Rainer Bielefeld Retired from comment #2)
> NOT reproducible with Server Installation of Version 7.3.0.0.alpha1+ (x64) 
> |   Build ID b8d17d754830ab57099dcdfa72a96bfad404ab1a  |  CPU threads: 12;
> OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win  |  Locale:
> de-DE (de_DE); UI: de-DE  |  Calc: CL  |  Special devUserProfileL  | 
> Colibri Theme 
> 
> @reporter:
> a) did you already test with a newly created user profile?

Yes, some look.

> b) your OS is WIN10?

Yes. Sorry forgot it.

Version: 7.2.3.2 (x64) / LibreOffice Community
Build ID: d166454616c1632304285822f9c83ce2e660fd92
CPU threads: 4; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: threaded
Comment 6 lol 2021-12-12 18:10:06 UTC
Sorry, I made a mistake. With a new user profile the UI looks fine. I mistake the user profile name in the bootstrap.ini.
Comment 7 lol 2021-12-12 18:36:06 UTC
I think I found the problem. This depends on the themes.

Steps to Reproduce:
1. Open a Writer document.
2. Dock three toolbars at the bottom.
3. Open Tools - Option... - LibreOffice - Personalisation
4. Select one of the six themes
5. Click Apply --> The UI breaks.

Select Default look and apply --> The UI looks fine.
Comment 8 lol 2021-12-12 18:39:24 UTC
Created attachment 176886 [details]
Default look
Comment 9 lol 2021-12-12 18:43:56 UTC
Created attachment 176887 [details]
Dark theme

The problem occurs with all six themes.
Comment 10 lol 2021-12-12 18:47:17 UTC
The some problem is already in LO 7.1.6.2.
Comment 11 V Stuart Foote 2021-12-12 18:56:14 UTC
OK confirmed. Much like bug 131023 the preinstalled themes for personalization have limits to which the graphics can be expanded for area fill the UI.

UI controls function correctly, this is just a visual glitch in the area fill for the theme graphics.

Work on bug 125217 may eventually refactor.

Version: 7.2.4.1 (x64) / LibreOffice Community
Build ID: 27d75539669ac387bb498e35313b970b7fe9c4f9
CPU threads: 8; OS: Windows 10.0 Build 19044; UI render: Skia/Vulkan; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: threaded