Bug 146232 - Poor look of lock overlay on encrypted files in Start Center with Colibre
Summary: Poor look of lock overlay on encrypted files in Start Center with Colibre
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.2.4.1 release
Hardware: All All
: medium minor
Assignee: Rizal Muttaqin
URL:
Whiteboard: target:7.4.0
Keywords: topicUI
Depends on:
Blocks: Start-Center Icon-Theme-Colibre
  Show dependency treegraph
 
Reported: 2021-12-15 06:53 UTC by Mike Kaganski
Modified: 2022-03-14 07:26 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Thumbnail with lock overlay (69.88 KB, image/gif)
2021-12-15 06:53 UTC, Mike Kaganski
Details
The transparanet pixels is standard in Colibre, how about this one? (39.21 KB, image/gif)
2022-02-21 00:16 UTC, Rizal Muttaqin
Details
Another design (81.80 KB, image/gif)
2022-03-10 10:22 UTC, Rizal Muttaqin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Kaganski 2021-12-15 06:53:30 UTC
Created attachment 176933 [details]
Thumbnail with lock overlay

Lock overlay icons used for password-protected files on Start Center (BMP_128X128_WRITER_DOC, BMP_128X128_CALC_DOC, BMP_128X128_IMPRESS_DOC, BMP_128X128_DRAW_DOC, BMP_128X128_MATH_DOC) seem to be using transparent pixels around the lock in Colibre theme. That looks poor on the start center, where the "shadow" around the lock seem to make the lock "patched" atop of the thumbnail.

The "shadow" should be either removed, or made non-transparent, to not create an "alien" impression of the lock.
Comment 1 stragu 2021-12-15 08:47:39 UTC
Reproduced with:

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 06ac18e6302d666c363740644a7976e8c22d1113
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

Version: 7.3.0.0.beta1 / LibreOffice Community
Build ID: 436f14c25ec1847646b953cf13d0db4f7ca3be57
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

Version: 7.2.4.1 / LibreOffice Community
Build ID: 27d75539669ac387bb498e35313b970b7fe9c4f9
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

In 7.1, the icon did not seem to have transparency, so has a black outline, which looks bad too.

Version: 7.1.7.2 / LibreOffice Community
Build ID: c6a4e3954236145e2acb0b65f68614365aeee33f
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

Setting to "minor", apologies if it's not warranted.
Comment 2 Rizal Muttaqin 2022-02-21 00:16:29 UTC
Created attachment 178417 [details]
The transparanet pixels is standard in Colibre, how about this one?
Comment 3 Heiko Tietze 2022-03-08 05:56:14 UTC
Looks much better now with intentional transparency. Better approach, however, would have been to have the lock as overlay since I don't know any other icon where we use this design. Anyway, fine for me to submit.
Comment 4 Mike Kaganski 2022-03-10 08:38:28 UTC
(In reply to Heiko Tietze from comment #3)
> Looks much better now with intentional transparency.

Agree.

> Better approach,
> however, would have been to have the lock as overlay since I don't know any
> other icon where we use this design.

Agree.

> Anyway, fine for me to submit.

Agree. :)
Comment 5 Rizal Muttaqin 2022-03-10 10:22:20 UTC
Created attachment 178771 [details]
Another design

How about this one?
Comment 6 Heiko Tietze 2022-03-10 11:41:27 UTC
(In reply to Rizal Muttaqin from comment #5)
> How about this one?

Here we come to very subjective opinions. I like the lock more than a key. It symbolize the situation more precisely. The key itself takes extra space at right but not at the bottom. Looks a bit unsymmetrical. I wonder if this icon shows well when scaled down to, eg. 32px. Not sure if that's a premise.
Comment 7 Mike Kaganski 2022-03-10 11:53:49 UTC
(In reply to Rizal Muttaqin from comment #5)

I can't tell about lock-vs-key difference. What I like more in this new image is the look without shadow, which IMO is better (and I suppose that a lock would look better in such design, too).
Comment 8 Commit Notification 2022-03-14 00:36:46 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d156995180b565f34b52859aa1d6953995a76b9a

Colibre: Resolves tdf#146232 Adjust lock overlay icons

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.