Bug 146292 - LibreOffice freezes when right-click in an empty document of any component or Click on the dropdown of toolbar buttons
Summary: LibreOffice freezes when right-click in an empty document of any component or...
Status: RESOLVED DUPLICATE of bug 146286
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.4.0.0 alpha0+
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2021-12-18 03:06 UTC by Kevin Suo
Modified: 2021-12-18 11:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
gdb backtrace (33.06 KB, text/x-log)
2021-12-18 03:14 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2021-12-18 03:06:04 UTC
Steps to Reproduce:
1. New Writer;
2. Right-click in the default 1st paragraph.

Current Result:
Freezes.

Expected Result:
The context menu should open.
Comment 1 Kevin Suo 2021-12-18 03:09:05 UTC
Bisected to:

commit b37f9fbf05e16eb58eae40c6d900a4b9da2972db
Author: Noel Grandin <noelgrandin@gmail.com>
Date:   Thu Dec 16 19:24:42 2021 +0200

    osl::Mutex->std::mutex in VCLXMenu

Adding cc to: Noel Grandin. Would you please take a look, thanks.


Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: b37f9fbf05e16eb58eae40c6d900a4b9da2972db
CPU threads: 8; OS: Linux 5.14; UI render: default; VCL: gtk3
Locale: zh-CN (zh_CN.UTF-8); UI: zh-CN
Build Platform: Fedora34@X64, Branch:master, bibisect-linux-64-7.4-CN
Calc: threaded

Fedora 34 x64, Gnome 40.4, Wayland.
Comment 2 Kevin Suo 2021-12-18 03:14:53 UTC
Created attachment 176990 [details]
gdb backtrace
Comment 3 Kevin Suo 2021-12-18 03:24:40 UTC
Also freezes in Calc and Draw.
Comment 4 Kevin Suo 2021-12-18 05:41:36 UTC
Also freezes when I click on the toolbar buttons such as New, Open, Save, Insert Fields on the Standard Toolbar.
Comment 5 Regina Henschel 2021-12-18 09:03:59 UTC
Same as bug 146286 ?
Comment 6 Kevin Suo 2021-12-18 09:15:25 UTC
(In reply to Regina Henschel from comment #5)
Maybe, but in my opinion let's keep them as separate for now. Adding to see also.
Comment 7 Julien Nabet 2021-12-18 11:04:57 UTC
On pc Debian x86-64 with master sources updated today, I got an hang with gen and gtk3 rendering.
Reading tdf#146286, it seems indeed a dup (even if it's not the same symptom)

*** This bug has been marked as a duplicate of bug 146286 ***