Bug 146308 - Right clicking on a line in an SVG hangs LibreOffice Draw
Summary: Right clicking on a line in an SVG hangs LibreOffice Draw
Status: RESOLVED DUPLICATE of bug 146286
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
7.4.0.0 alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-18 20:40 UTC by Hossein
Modified: 2021-12-18 21:59 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample SVG file that causes LibreOffice Draw to hang (663 bytes, image/svg+xml)
2021-12-18 20:41 UTC, Hossein
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hossein 2021-12-18 20:40:21 UTC
Description:
While opening an example SVG file, right clicking the line causes LibreOffice to hang. The user then have to end task the LibreOffice.

Steps to Reproduce:
1. Open LibreOffice with any UI (preferably gtk3)
2. Open the attachment wrong-text-1.svg
3. Right click on the vertical line.

Actual Results:
LibreOffice Draw does stops responding to user inputs. If the gtk3 ui is used, a message appears that says:

"libreofficedev-draw" is not responding.
You may choose to wait a short while for it to continue or force the application to quit entirely.
[Force Quit]             [Wait]

Expected Results:
The context menu for the vertical line should appear.


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: b329502b23c59ff605ff02c3054f1bd2599dde08
CPU threads: 8; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Hossein 2021-12-18 20:41:10 UTC
Created attachment 177007 [details]
Sample SVG file that causes LibreOffice Draw to hang
Comment 2 Julien Nabet 2021-12-18 21:59:59 UTC

*** This bug has been marked as a duplicate of bug 146286 ***