Bug 146378 - Solver dialog is disappeared after switching to Writer window and back to Calc window
Summary: Solver dialog is disappeared after switching to Writer window and back to Cal...
Status: RESOLVED DUPLICATE of bug 146913
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Solver
  Show dependency treegraph
 
Reported: 2021-12-22 20:01 UTC by Roman Kuznetsov
Modified: 2022-01-27 13:19 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2021-12-22 20:01:27 UTC
Description:
Solver dialog is disappeared after switching to Writer window and back to Calc window

Steps to Reproduce:
1. Open Writer
2. Open Calc
3. Select in Calc Tools-Solver =>you see Solver dialog
4. Go to Writer window
5. Go back to Calc window => you don't see Solver dialog it is just disappeared together with your options

Actual Results:
Solver dialog is disappeared after switching to Writer window and back to Calc window

Expected Results:
Solver dialog is always here after switching to Writer window and back to Calc window


Reproducible: Always


User Profile Reset: No



Additional Info:
Версия: 6.3.3.2 (x64)
ID сборки: a64200df03143b798afd1ec74a12ab50359878ed
Потоков ЦП: 4; ОС:Windows 10.0; Отрисовка ИП: по умолчанию; VCL: win; 
Локаль: ru-RU (ru_RU); Язык интерфейса: ru-RU
Calc: threaded

but not in 6.2 => regression

I bisected this one in win32-6.3 bisect repo and got the SHA

https://git.libreoffice.org/core/commit/228723ea962e33b472317b41f31b032421879093

https://gerrit.libreoffice.org/c/core/+/70903

Added to CC: Caolán McNamara

Caolán could you please look at it? Thank you
Comment 1 Roman Kuznetsov 2021-12-22 20:13:35 UTC
Caolán, I see the same problem with all Statistic's dialogs and with Goal Seek dialog. Please check it too at once. Thank you
Comment 2 Roman Kuznetsov 2021-12-22 20:15:54 UTC
(In reply to Roman Kuznetsov from comment #1)
> Caolán, I see the same problem with all Statistic's dialogs and with Goal
> Seek dialog. Please check it too at once. Thank you

And "Multiple operations" dialog and "Consolidate" dialog too
Comment 3 Roman Kuznetsov 2021-12-22 20:18:21 UTC
of course I see the problem in 

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 06ac18e6302d666c363740644a7976e8c22d1113
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Vulkan; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: threaded
Comment 4 raal 2021-12-25 18:14:58 UTC
Confirm with Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: c13db6e792cc347ffff4585f23866f195651f21f
CPU threads: 4; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded Jumbo
Comment 5 Caolán McNamara 2022-01-27 12:29:25 UTC
Is this a duplicate of bug 146913 ? which is fixed in current trunk.
Comment 6 Roman Kuznetsov 2022-01-27 13:19:06 UTC
Closed as dupe of the bug 146913

Thanks Caolán for fixing

*** This bug has been marked as a duplicate of bug 146913 ***