Bug 146402 - LibreOffice aborts when starting with an empty profile (Windows + probably AMD GPU)
Summary: LibreOffice aborts when starting with an empty profile (Windows + probably AM...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
7.4.0.0 alpha0+ Master
Hardware: All Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:7.4.0
Keywords: bibisected, bisected, regression
: 146581 148656 (view as bug list)
Depends on:
Blocks: Skia
  Show dependency treegraph
 
Reported: 2021-12-24 09:23 UTC by Aron Budea
Modified: 2022-04-19 05:11 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Skia log (154 bytes, text/plain)
2021-12-24 13:54 UTC, Aron Budea
Details
Skia log (w Radeon Software Adrenalin 21.10.2) (154 bytes, text/plain)
2022-01-06 12:42 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2021-12-24 09:23:31 UTC
As stated in the summary. I haven't checked with a release build.
Device is an AMD CPU with integrated graphics.

Bisected to the following commit. Adding CC: to Luboš Luňák.

https://cgit.freedesktop.org/libreoffice/core/commit/?id=4a11c85baeb4998e12bc2ab45b0c23d7203bd5b0
author		Luboš Luňák <l.lunak@collabora.com>	2021-11-25 22:38:55 +0100
committer	Luboš Luňák <l.lunak@collabora.com>	2021-11-29 21:48:53 +0100

remove Skia kDifference workaround
Comment 1 Aron Budea 2021-12-24 09:46:12 UTC
I tried to check this in Linux as well, but apparently the following command doesn't work anymore, UI mode remains default:
SAL_USE_VCLPLUGIN=gen SAL_ENABLESKIA=1 ./soffice
Comment 2 Aron Budea 2021-12-24 13:54:02 UTC
Created attachment 177126 [details]
Skia log

Daily (release) build from 12-22 doesn't start at all. So this isn't debug-only.
Comment 3 V Stuart Foote 2021-12-24 15:19:17 UTC
Can not reproduce on Windows 10 (21H2) with Intel Iris GPU

Vendor: 0x8086
Device: 0x8a52
API: 1.2.195
Driver: 0.404.1069
DeviceType: integrated
DeviceName: Intel(R) Iris(R) Plus Graphics
Denylisted: no

@Aaron, maybe figure out what AMD GPU details you have (the Skia.log from release build) and manually add an appropriate stanza to the "skia_denylist_vulkan.xml" in the <$ORIGIN>\share\skia folder?  Having the deny list may bypass the SkiaHelper util?
Comment 4 Aron Budea 2021-12-25 13:50:52 UTC
Yep, thanks for the hint, that helped.
I've found a list of driver versions: https://gpuopen.com/version-table/

This driver isn't the newest, 20.4.2/20.5.1, and it's installed by Windows 10 21H2 by default. Not installing a newer one while having the old driver around could be helpful.
Comment 5 Aron Budea 2022-01-05 08:19:58 UTC
*** Bug 146581 has been marked as a duplicate of this bug. ***
Comment 6 Aron Budea 2022-01-05 08:21:59 UTC
Confirmed via duplicate bug 146581.
Comment 7 Luboš Luňák 2022-01-06 09:41:33 UTC
Could you try temporarily installing the newest driver and check if the crash is fixed by that (and provide skia.log if that's the case)?
Comment 8 Aron Budea 2022-01-06 12:42:39 UTC
Created attachment 177346 [details]
Skia log (w Radeon Software Adrenalin 21.10.2)

I have mixed results after upgrading to Radeon Software Adrenalin 21.10.2 (current WHQL driver).

In today's daily build all is well, LO starts with Skia enabled (log attached).
In a fresh debug build after a pull (7.4.0.0.alpha0+ (x64), 302b44125aa0c1d5216f986ecf8e341cd6e57418), I get the aborts during start. After a few attempts at starting LO I end up with Skia/Raster. Switching off forced software rendering successfully ends up with Skia/Vulkan after restarting LO.

Thus I guess the user-facing problem could be solved by blacklisting the old drivers.
Comment 9 Luboš Luňák 2022-01-12 14:24:43 UTC
Thank you, that's the same driver version I currently have, so let's block anything older and by the time 7.4 is out that's hopefully good enough.
Comment 10 Commit Notification 2022-01-12 14:24:53 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6fd4209a7e5884e44f4214342c7565229aa9b7d5

block amd drivers that crash with Skia's kDifference (tdf#146402)

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Buovjaga 2022-04-19 05:11:26 UTC
*** Bug 148656 has been marked as a duplicate of this bug. ***