Bug 146427 - Add handwriting font
Summary: Add handwriting font
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.2.2.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Fonts-Bundled
  Show dependency treegraph
 
Reported: 2021-12-26 19:10 UTC by jsv
Modified: 2021-12-26 20:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jsv 2021-12-26 19:10:33 UTC
Description:
From what I can see here https://wiki.documentfoundation.org/Fonts,
there are no handwriting fonts shipped with LibreOffice.

I think that there should be at least some of them.
I think that having one or two of them with LibreOffice would be great.

Steps to Reproduce:
-

Actual Results:
-

Expected Results:
-


Reproducible: Always


User Profile Reset: No



Additional Info:
-
Comment 1 V Stuart Foote 2021-12-26 20:13:35 UTC
Script / hand-writing fonts are considered decorative and something of personal preference.

No need for them in bundled LibreOffice core fonts as users can use *any* on system font they have selectively installed, and such font can be selectively embedded in any ODF archive.
Comment 2 jsv 2021-12-26 20:53:42 UTC
It depends on what exactly we mean under handwriting font.

If you mean a calligraphy font, I agree with you.

But a font that looks like "everyday writing of an average person" is a good idea, imo.

Look at Segoe super family, which is somewhat the default for Windows UI.

It consists of three sans-serif fonts, two handwriting fonts, and two special fonts (emojis and symbols).

On a personalm side, I interested to have such font bundled with LO because I need a font that will be used for "rough draft" documents. When I open such a document, I need immediately see that I should not bother about grammar, punctuation, clear syntax, and so on. Just a draft, like something you have quickly wrote by hand sitting in the kitchen.