Bug 146435 - Text replacement error when track-changes is ON and show changes is OFF
Summary: Text replacement error when track-changes is ON and show changes is OFF
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.4.7.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 147402 (view as bug list)
Depends on:
Blocks: Track-Changes
  Show dependency treegraph
 
Reported: 2021-12-27 14:51 UTC by Lars Jødal
Modified: 2022-05-18 11:38 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshots demonstrating the bug (51.23 KB, application/pdf)
2021-12-27 14:59 UTC, Lars Jødal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lars Jødal 2021-12-27 14:51:55 UTC
Description:
Using LO Writer to edit text with track-changes has a strange replacement bug. When editing text with track-changes ON (to track the changes) while show changes is OFF (to avoid the clutter of changes when reading the text), correction of spelling errors using the system leaves the erroneous word on the screen, ADDING the correctly spelled word instead of REPLACING the erroneous word.



Steps to Reproduce:
1. Write text in LO Write (or use existing text) with track-changes OFF. The text should contain a spelling error, underlined by the spell checker.
2. Turn track-changes ON, and show changes OFF.
3. Point mouse to the underlined word and replace by suggestion from pop-up menu.



Actual Results:
The correctly spelled word is ADDED to the text shown on the screen.

Expected Results:
The correctly spelled word should REPLACE the text shown on the screen.



Reproducible: Always


User Profile Reset: No



Additional Info:
Versions: 
Checking older versions, this bug appears first in LO version 6.4.7.1 (not present in 6.4.6.2).

Present in current fresh version:
Version: 7.2.4.1 (x64) / LibreOffice Community
Build ID: 27d75539669ac387bb498e35313b970b7fe9c4f9
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: da-DK (da_DK); UI: da-DK
Calc: threaded
Comment 1 Lars Jødal 2021-12-27 14:59:17 UTC
Created attachment 177154 [details]
Screenshots demonstrating the bug

The attached screenshots (pdf file) demonstrates the problem.
Comment 2 Mike Kaganski 2021-12-27 16:30:49 UTC
Repro with Version: 7.2.4.1 (x64) / LibreOffice Community
Build ID: 27d75539669ac387bb498e35313b970b7fe9c4f9
CPU threads: 12; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: CL

No repro with Version: 5.0.0.5 (x64)
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: ru-RU (ru_RU)
Comment 3 raal 2021-12-29 16:33:42 UTC
This seems to have begun at the below commit.
Adding Cc: to Michael Stahl; Could you possibly take a look at this one?
Thanks
 63ab95d31c0ceda0e6a6744b0b9242758bc9ba95 is the first bad commit
commit 63ab95d31c0ceda0e6a6744b0b9242758bc9ba95
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Thu Aug 20 14:46:38 2020 +0200

    source sha:ec579354af954867b829e7d08e4d752518c83728

https://git.libreoffice.org/core/+/ec579354af954867b829e7d08e4d752518c83728
    tdf#135721 sw: fix spell check context menu deleting flys
Comment 4 Gabor Kelemen (allotropia) 2022-02-15 08:55:13 UTC
*** Bug 147402 has been marked as a duplicate of this bug. ***
Comment 5 Telesto 2022-04-06 12:04:58 UTC Comment hidden (obsolete)
Comment 6 Gabor Kelemen (allotropia) 2022-05-18 09:45:22 UTC
I cannot reproduce this anymore in:

Version: 7.4.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: b2467d6c7af988f8ed4e090ebf9472be6c84fb06
CPU threads: 14; OS: Windows 10.0 Build 19044; UI render: default; VCL: win
Locale: en-US (hu_HU); UI: en-US
Calc: threaded

Probably because of the fix to similar bug 147220
Comment 7 Lars Jødal 2022-05-18 11:38:41 UTC
Agreed, the bug is no longer reproducible in:

Version: 7.4.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: b2467d6c7af988f8ed4e090ebf9472be6c84fb06
CPU threads: 4; OS: Windows 10.0 Build 19043; UI render: Skia/Vulkan; VCL: win
Locale: da-DK (da_DK); UI: da-DK
Calc: threaded

Changing status to RESOLVED FIXED.