Bug 146462 - Field Dialog: Not able to insert cross reference any more: the Insert > Cross Reference dialog shows no Table or Figure entries
Summary: Field Dialog: Not able to insert cross reference any more: the Insert > Cross...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.4.0.0 alpha0+
Hardware: All Linux (All)
: high major
Assignee: Michael Stahl (allotropia)
URL:
Whiteboard: target:7.4.0
Keywords: bibisected, bisected, regression
: 146564 (view as bug list)
Depends on:
Blocks: Cross-reference-dialog
  Show dependency treegraph
 
Reported: 2021-12-29 01:25 UTC by Kevin Suo
Modified: 2022-02-08 07:18 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
testCrossRef.odt (10.22 KB, application/vnd.oasis.opendocument.text)
2021-12-29 01:25 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2021-12-29 01:25:21 UTC
Created attachment 177180 [details]
testCrossRef.odt

The attached test odt file contains a simple Table (numbered range) index and a simple Figure (numbered range) index. However, if you go to Insert > Cross Reference, the table and figure are not shown in the reference list box.

Steps to Reproduce:
1. Open the attached test ODT file.
2. Put cursor to the highlighted text (or to any other place), then go to "Insert > Cross Reference".
3. Select Table or Figure category.

--> Nonthing shows in the list on the right side.

It is expected that one figure and one table is shown within the corresponding category.

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 1bb0e177124d5d6661b72df6c7d848fb23639652
CPU threads: 8; OS: Linux 5.14; UI render: default; VCL: gtk3
Locale: zh-CN (zh_CN.UTF-8); UI: zh-CN
Build Platform: Fedora34@X64, Branch:master, bibisect-linux-64-7.4-CN
Calc: threaded
Comment 1 Kevin Suo 2021-12-29 01:27:57 UTC
Bibisected to:
$ git log 7d5984d7a..d53b9c69e --format=reference 
d53b9c69e24d (osl::Mutex->std::mutex in UndoManagerHelper_Impl, 2021-12-18)
833b240d1d04 (Update git submodules, 2021-12-20)
40487d9c81c6 (tdf#145062 sw: try to fix UBSan crash in UITest, 2021-12-17)

whereas 40487d9c81c6 seems to be related.

commit 40487d9c81c69c4e5ee1621e53c8162ae33c80b2
Author: Michael Stahl <michael.stahl@allotropia.de>
Date:   Fri Dec 17 18:46:29 2021 +0100

    tdf#145062 sw: try to fix UBSan crash in UITest

Adding Michael Stahl to cc: could you please take a look? Thanks.
Comment 2 stragu 2021-12-29 15:30:57 UTC
Confirmed in:

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 7fe2ce55ab86cc7a32850fdf504e368c535949c3
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

But 7.3 beta1 is OK:

Version: 7.3.0.0.beta1 / LibreOffice Community
Build ID: 436f14c25ec1847646b953cf13d0db4f7ca3be57
CPU threads: 8; OS: Linux 5.4; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded
Comment 3 Xisco Faulí 2022-01-13 09:07:07 UTC
*** Bug 146564 has been marked as a duplicate of this bug. ***
Comment 4 sdc.blanco 2022-01-25 10:10:03 UTC
Same problem experienced with Headings
Comment 5 Commit Notification 2022-02-04 18:50:10 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6d5f22585003e1b0091eefad9d6a2446a1b510d1

tdf#146462 sw: fix broken CrossReference field tab page

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Michael Stahl (allotropia) 2022-02-04 18:50:25 UTC
fixed on master
Comment 7 Commit Notification 2022-02-08 07:18:09 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d4d16e26a7deb5bfddc9736b4cc9e87c5f6704ee

tdf#146462: sw: Add UItest

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.