Bug 146552 - DRAW: Export Functionality (deprecated efficiency)
Summary: DRAW: Export Functionality (deprecated efficiency)
Status: RESOLVED DUPLICATE of bug 144195
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Graphics-Export Image-DPI
  Show dependency treegraph
 
Reported: 2022-01-03 16:14 UTC by steven.misshula
Modified: 2022-01-04 10:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshots of 7.1 Export Functionality (317.10 KB, image/jpeg)
2022-01-03 16:14 UTC, steven.misshula
Details

Note You need to log in before you can comment on or make changes to this bug.
Description steven.misshula 2022-01-03 16:14:31 UTC
Created attachment 177290 [details]
Screenshots of 7.1 Export Functionality

Exporting a graphic to a PNG file while controlling the resolution has now added a step from the ver 7.1

BACKGROUND:
In 7.1 when I exported a file I would tab through the options, leaving the dimensions "as is" and change the resolution to my preference.  This would then automatically change the dimension "visibly" in the dialogue box.

CURRENT ISSUE:
In ver 7.2 there is now a radial button for choosing "DIMENSIONS" or "RESOLUTION".

When changing on or the other, the "other" is grayed out - implying that there has been no change to that docuement characteristic.  Example:  Increaseing resolution will shrink the image dimensions.  HOWEVER, the change in dimension is not reflected in the dialogue box.  The change is only discovered when the user mouse clicks on the radial button to change the dimension.

VIOLATION OF UX-DESIGN --> EFFICIENCY:
As I experience it, this new feature is a violation of UX-Efficiency in that:

1)  The TAB feature skips over the radial button
2)  The Dimension or Resolution change is obfuscated to the user
3)  An extra step has been added to export when choosing to control Resolution AND Dimension.
Comment 1 Heiko Tietze 2022-01-04 08:44:20 UTC
Please read comments at bug 115464 and see also for the reason to this change.

(In reply to steven.misshula from comment #0)
> 1)  The TAB feature skips over the radial button
True

> 2)  The Dimension or Resolution change is obfuscated to the user
Not true. Or rather not done at 100%. In fact the controls become disabled depending on what radio button is checked. And to make it perfectly clear we should also disable the unit dropdown.

> 3)  An extra step has been added to export when choosing to control
> Resolution AND Dimension.
By design, see bug 115464
Comment 2 Telesto 2022-01-04 10:33:11 UTC
(In reply to Heiko Tietze from comment #1)
Well I agree with initial poster (comment 0). The current design not being 'it'. Not saying the old design being OK either. 
See bug 144195 (with number of off-topic comments), and especially comment bug 144195 comment 10
Comment 3 Heiko Tietze 2022-01-04 10:36:02 UTC
Good point, let's discuss on bug 144195.

*** This bug has been marked as a duplicate of bug 144195 ***