Bug 146562 - UI: Table of content dialog position to parent is off (dialog doesn't open centered to main screen)
Summary: UI: Table of content dialog position to parent is off (dialog doesn't open ce...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All All
: low minor
Assignee: Caolán McNamara
URL:
Whiteboard: target:7.4.0 target:7.3.2
Keywords: bibisected, bisected, regression
: 147125 (view as bug list)
Depends on:
Blocks: TableofContents-Indexes-Dialog
  Show dependency treegraph
 
Reported: 2022-01-04 10:38 UTC by Telesto
Modified: 2022-03-25 16:18 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2022-01-04 10:38:57 UTC
Description:
UI: Table of content dialog position to parent is off (dialog doesn't open centered to main screen)

Steps to Reproduce:
1. Open Writer
2. Insert -> Table of content and index
3. Table of content or

Actual Results:
attachment 177134 [details]

Expected Results:
attachment 177135 [details]


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 1bb0e177124d5d6661b72df6c7d848fb23639652
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2022-01-04 10:42:04 UTC
Also in
Version: 7.1.0.0.beta1+ (x64)
Build ID: f9fab4203c1aa0b9a3f27ce2713b6d5addc7df19
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

and in
6.3

ok with
Version: 6.1.0.0.beta1+
Build ID: da49f4aeb8d5e9a7d2cba8855d911e7cc1d2f1e2
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 2 Buovjaga 2022-01-15 08:50:18 UTC
Bibisected with linux-64-6.3 to https://git.libreoffice.org/core/commit/389491aedd659a3c4b24b9902b6cb54075874d3e

weld SwMultiTOXTabDialog
Comment 3 Dieter 2022-02-21 14:02:24 UTC
*** Bug 147125 has been marked as a duplicate of this bug. ***
Comment 4 Caolán McNamara 2022-02-22 12:32:17 UTC
There is a "always center this dialog" option available in a pinch, but it would be better to know why this happens before using that. It kind of looks like its positioned before showing the preview part
Comment 5 Dieter 2022-02-22 18:50:43 UTC
Same with "Find and Replace" dialog; see bug 147304.
Comment 6 Commit Notification 2022-03-07 12:54:27 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e0b373227e135230bd9e678cbf9a6a56d4f3248a

tdf#146562 let toc default size and pos on first launch

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Caolán McNamara 2022-03-07 12:55:13 UTC
done in trunk, backport to 7-3 in gerrit
Comment 8 Commit Notification 2022-03-07 14:01:53 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/d9f852786aa3d54eb201fae674990bec8a10ed5e

tdf#146562 let toc default size and pos on first launch

It will be available in 7.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Dieter 2022-03-25 16:18:15 UTC
VERIFIED with

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: e8c95b796626cb9db163f5d563fa67f38a5e92b0
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Caolán, thanks for fixing it!