Bug 146564 - Headings are not listed in cross-reference dialog
Summary: Headings are not listed in cross-reference dialog
Status: RESOLVED DUPLICATE of bug 146462
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.4.0.0 alpha0+
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bisected, regression
Depends on:
Blocks:
 
Reported: 2022-01-04 11:13 UTC by Heiko Tietze
Modified: 2022-01-13 09:07 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
not reproducible (31.01 KB, image/png)
2022-01-04 14:55 UTC, Xisco Faulí
Details
Screencast of the issue using VCL=gen (84.02 KB, image/gif)
2022-01-05 08:14 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2022-01-04 11:13:06 UTC
Enter two paragraphs (eg. Foo and Bar), make it a heading (eg. by selecting and pressing ctrl+1), and try to Insert > Cross-reference: Headings. The selection list remains empty so nothing can be picked up to insert. Applies to other types too.

Works well with 7.2.4.1 but not with 

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 383616c2c0c9e6874a714d7f494e5a2ec1a3f08d
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: kf5 (cairo+xcb)
Locale: de-DE (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2022-01-04 14:54:54 UTC
I can't reproduce in

Version: 7.3.0.0.beta1+ / LibreOffice Community
Build ID: 86f539a23b08d0cc9e5e9566ac31380e373be13f
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 2 Xisco Faulí 2022-01-04 14:55:12 UTC
Created attachment 177307 [details]
not reproducible
Comment 3 Xisco Faulí 2022-01-04 15:47:39 UTC
Does it work for you with SAL_USE_VCLPLUGIN=gen ?
Comment 4 Heiko Tietze 2022-01-05 08:14:41 UTC
Created attachment 177321 [details]
Screencast of the issue using VCL=gen

(In reply to Xisco Faulí from comment #3)
> Does it work for you with SAL_USE_VCLPLUGIN=gen ?

Yes, same result with gen and build from master this morning.
Comment 5 psidiumcode 2022-01-12 19:43:26 UTC
I could reproduce it in ver:
Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: b4a281af53efa0c36ee1770e6cf4d800be77a6d2
CPU threads: 12; OS: Mac OS X 10.15.7; UI render: default; VCL: osx
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded

I could not reproduce it in ver:
Version: 7.2.5.2 / LibreOffice Community
Build ID: 499f9727c189e6ef3471021d6132d4c694f357e5
CPU threads: 12; OS: Mac OS X 10.15.7; UI render: default; VCL: osx
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded
Comment 6 psidiumcode 2022-01-12 19:44:55 UTC
Bisected with mac64-7.4 repo.
 c78f2f3472d1110e6ff88d1094a4e249e2b24cbf is the first bad commit
commit c78f2f3472d1110e6ff88d1094a4e249e2b24cbf
Author: libreoffice <libreoffice@libreoffices-MacBook-Air.local>
Date:   Fri Dec 24 23:50:52 2021 +0100

    source sha:40487d9c81c69c4e5ee1621e53c8162ae33c80b2
    
    source sha:40487d9c81c69c4e5ee1621e53c8162ae33c80b2

 .../Contents/Frameworks/libswuilo.dylib            | Bin 2481808 -> 2481992 bytes
 .../Contents/Resources/config/images_breeze.zip    | Bin 1897459 -> 1897459 bytes
 .../Resources/config/images_breeze_dark.zip        | Bin 1893132 -> 1893132 bytes
 .../Resources/config/images_breeze_dark_svg.zip    | Bin 1574850 -> 1574850 bytes
 .../Resources/config/images_breeze_svg.zip         | Bin 1572323 -> 1572323 bytes
 .../Contents/Resources/config/images_colibre.zip   | Bin 2752860 -> 2752860 bytes
 .../Resources/config/images_colibre_svg.zip        | Bin 2894747 -> 2894747 bytes
 .../Resources/config/images_elementary.zip         | Bin 4206629 -> 4206629 bytes
 .../Resources/config/images_elementary_svg.zip     | Bin 5531757 -> 5531757 bytes
 .../Resources/config/images_karasa_jaga.zip        | Bin 4845240 -> 4845240 bytes
 .../Resources/config/images_karasa_jaga_svg.zip    | Bin 19324292 -> 19324292 bytes
 .../Contents/Resources/config/images_sifr.zip      | Bin 2116787 -> 2116787 bytes
 .../Contents/Resources/config/images_sifr_dark.zip | Bin 2118725 -> 2118725 bytes
 .../Resources/config/images_sifr_dark_svg.zip      | Bin 1767488 -> 1767488 bytes
 .../Contents/Resources/config/images_sifr_svg.zip  | Bin 1763591 -> 1763591 bytes
 .../Contents/Resources/config/images_sukapura.zip  | Bin 3048726 -> 3048726 bytes
 .../Resources/config/images_sukapura_svg.zip       | Bin 4367096 -> 4367096 bytes
 LibreOffice.app/Contents/Resources/setuprc         |   2 +-
 LibreOffice.app/Contents/Resources/versionrc       |   2 +-
 19 files changed, 2 insertions(+), 2 deletions(-)
Comment 7 psidiumcode 2022-01-12 19:45:21 UTC
Bisect log:

# bad: [085663954c867ee25897f2071597404822728be7] source sha:840cc7883849a10eea11a02a743848238723a3de
# good: [649d50e5b34d9d4f9ba89283baaea9b3fcb28fbc] source sha:229123ccc6f90ebf66b3e659bebbd53f8a9bdd3a
git bisect start 'master' 'oldest'
# good: [dbbfa769523561ee6a29d99198d8ecd2bd505f0b] source sha:729834abac1618aa2f0dcc6d774deb74f7c42bb3
git bisect good dbbfa769523561ee6a29d99198d8ecd2bd505f0b
# bad: [238db65e00460c3021f1dd6d6357eeeb9440996f] source sha:0c920406888f141d163ce2df01e707404f9e7acd
git bisect bad 238db65e00460c3021f1dd6d6357eeeb9440996f
# bad: [abc38faf57f7abbfcc9b65ec0570da6058086587] source sha:132d652ad1af4ec067fe08e388e8ddba963ddc2b
git bisect bad abc38faf57f7abbfcc9b65ec0570da6058086587
# bad: [58963b2877dacea0648c5d44d44014add29cee59] source sha:82233965486f88f4ce1313dcf35b4bc688e1832a
git bisect bad 58963b2877dacea0648c5d44d44014add29cee59
# bad: [55dd99a4e6aaa3000e1f21a5a4f89f95b8580d04] source sha:97d00de4afe9827ddaf299cfdfa8534425a11fe6
git bisect bad 55dd99a4e6aaa3000e1f21a5a4f89f95b8580d04
# good: [d19e0208a817fec068829da448858867c0552e8e] source sha:7fe0a4cddf23f0c15e95ff59e658ee3bbe11db51
git bisect good d19e0208a817fec068829da448858867c0552e8e
# bad: [c78f2f3472d1110e6ff88d1094a4e249e2b24cbf] source sha:40487d9c81c69c4e5ee1621e53c8162ae33c80b2
git bisect bad c78f2f3472d1110e6ff88d1094a4e249e2b24cbf
# good: [3962cd3f4b694a955e7a992dbefd829a6ae05f62] source sha:599cb40c92f2d758d21c7040790cbf2ceab213f3
git bisect good 3962cd3f4b694a955e7a992dbefd829a6ae05f62
# good: [a5f0c3121412b0ea7d20aa52cfb0616026a1810f] source sha:38768976f82834010f160cc234eade5ca5aeefa5
git bisect good a5f0c3121412b0ea7d20aa52cfb0616026a1810f
# good: [51e86d54f002b00cd853c86d11c934bd685a65dc] source sha:7d5984d7aed2bafcb599882b66bb0dde2d22ff3f
git bisect good 51e86d54f002b00cd853c86d11c934bd685a65dc
# first bad commit: [c78f2f3472d1110e6ff88d1094a4e249e2b24cbf] source sha:40487d9c81c69c4e5ee1621e53c8162ae33c80b2
Comment 8 Heiko Tietze 2022-01-13 09:03:05 UTC Comment hidden (off-topic)
Comment 9 Xisco Faulí 2022-01-13 09:07:07 UTC
According to the bisect log in comment 6 this was introduced by https://cgit.freedesktop.org/libreoffice/core/commit/?id=40487d9c81c69c4e5ee1621e53c8162ae33c80b2, thus, closing as duplicated of bug 146462

*** This bug has been marked as a duplicate of bug 146462 ***