Bug 146690 - FILESAVE PPTX: Textbox with only newlines doesn't preserve text size on save
Summary: FILESAVE PPTX: Textbox with only newlines doesn't preserve text size on save
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Sarper Akdemir
URL:
Whiteboard: target:7.4.0 target:7.3.2
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-10 22:39 UTC by Sarper Akdemir
Modified: 2022-03-23 13:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Reproducer from PowerPoint with textbox that changes size on roundtrip (13.04 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2022-01-10 22:45 UTC, Sarper Akdemir
Details
Original file screen capture from MSO PowerPoint (8.46 KB, image/jpeg)
2022-01-10 22:47 UTC, Sarper Akdemir
Details
After roundtrip on LibreOffice Impress (3.08 KB, image/png)
2022-01-10 22:48 UTC, Sarper Akdemir
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sarper Akdemir 2022-01-10 22:39:50 UTC
Description:
Textbox made up from multiple newlines with font size 5 from PowerPoint, opens without a problem on Impress but on save&reload appears with different size since font size isn't preserved and becomes 18 on save.

Steps to Reproduce:
1. Open attached file with Impress
2. Observe textbox size and font size
3. Save to PPTX and reload on Impress

Actual Results:
The textbox size changes, since font size isn't preserved.

Expected Results:
The textbox should be observed the same, font size shouldn't change.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
See attached file, and the screen captures attached.
Comment 1 Sarper Akdemir 2022-01-10 22:45:46 UTC
Created attachment 177448 [details]
Reproducer from PowerPoint with textbox that changes size on roundtrip
Comment 2 Sarper Akdemir 2022-01-10 22:47:40 UTC
Created attachment 177449 [details]
Original file screen capture from MSO PowerPoint
Comment 3 Sarper Akdemir 2022-01-10 22:48:20 UTC
Created attachment 177450 [details]
After roundtrip on LibreOffice Impress
Comment 4 Gerald Pfeifer 2022-02-02 09:13:13 UTC
I already could reproduce this issue with LO 6.4:

Version: 6.4.8.0.0+
Build ID: 99b065ec31d032fc08ab14f66430dac4fef904a5
CPU threads: 8; OS: Linux 5.16; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:libreoffice-6-4, Time: 2020-10-08_08:57:08

So it does not appear to be a regression, unlike bug #147121 which
looks very similar, but regressed between 7.1 and 7.2.
Comment 5 Commit Notification 2022-02-20 12:49:19 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/c92aa69bc63ffb2dddbde0bfb3fe80c7de67a06f

tdf#146690: pptx export: fix endParaRPr size value for empty paragraphs

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2022-02-21 16:34:26 UTC
Sarper Akdemir committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/c6dc94b147fdf522552640918cc1d1ef246eb04d

tdf#146690: pptx export: fix endParaRPr size value for empty paragraphs

It will be available in 7.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Gerald Pfeifer 2022-02-22 11:10:24 UTC
I reproduced both the original issue with the daily build some two
days ago and now verified the fix with yesterday's build

  Version: 7.4.0.0.alpha0+ / LibreOffice Community
  Build ID: 522bde9470bbb321813fa5f1ca8e3c2ebb1bb5cc
  CPU threads: 8; OS: Linux 5.16; UI render: default; VCL: gtk3
  Locale: en-US (en_US.UTF-8); UI: en-US

Thank you, Sarper!
Comment 8 Xisco Faulí 2022-03-23 13:52:13 UTC
*** Bug 134401 has been marked as a duplicate of this bug. ***