Bug 146709 - Copy values from filtered data should not include de-selected cells
Summary: Copy values from filtered data should not include de-selected cells
Status: RESOLVED DUPLICATE of bug 118858
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.1.4.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-11 22:21 UTC by dacoex
Modified: 2022-01-12 10:17 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dacoex 2022-01-11 22:21:06 UTC
Description:
Copying values from a range of data which was selected using auto-filters does not only yield the selection but the whole table data.

The same applies to formulas applied on a selection: they include all data, i.e. also the deselected cells.

Steps to Reproduce:
1. Add auto filter to a table
2. select data by applying filter
3. copy filtered values
4. paste into text editor



Actual Results:
All data in a table

Expected Results:
only selected rows


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.2.5.2 / LibreOffice Community
Build ID: 20(Build:2)
Locale: de-DE (de_DE.UTF-8); UI: de-DE
Ubuntu package version: 1:7.2.5~rc2-0ubuntu0.21.10.1~lo1
Calc: threaded
Comment 1 m.a.riosv 2022-01-12 10:17:35 UTC

*** This bug has been marked as a duplicate of bug 118858 ***