Bug 146739 - some keyboard custom shortcut no more working
Summary: some keyboard custom shortcut no more working
Status: RESOLVED DUPLICATE of bug 146174
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.2.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 147062 (view as bug list)
Depends on:
Blocks: GTK3
  Show dependency treegraph
 
Reported: 2022-01-13 14:46 UTC by Duns
Modified: 2022-04-05 07:45 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Tools - Customize (66.60 KB, image/png)
2022-01-29 12:23 UTC, raal
Details
alt+i (67.25 KB, image/png)
2022-01-29 15:26 UTC, Duns
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Duns 2022-01-13 14:46:50 UTC
After upgrading to Version: 7.2.5.2 not all, but some custom shortcut doesn't work anymore. F.e. alt+I : now is always menu - insert, even I have alt + i as a given style.
Comment 1 raal 2022-01-29 12:23:02 UTC
Created attachment 177901 [details]
Tools - Customize

What do you have in Tools-Customize-Keyboard > Alt+I ?
Comment 2 Duns 2022-01-29 15:14:51 UTC
I have, as in the past, a Character style ("italiano"). Before last update it worked well. Now I get -> menu - insert.
Comment 3 Duns 2022-01-29 15:26:31 UTC
Created attachment 177905 [details]
alt+i

as you may see, alt+I, in my LO, is setted to call a style, non to call a drop-down menu.
Comment 4 raal 2022-01-29 17:04:31 UTC
I can confirm with Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 2f4f4cbeb8e50081d607b86b0475b93971c40ab8
CPU threads: 4; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded Jumbo

Works in LO 7.1, regression.
Comment 5 raal 2022-01-29 17:18:20 UTC
This seems to have begun at the below commit.
Adding Cc: to Caolán McNamara; Could you possibly take a look at this one?
Thanks
 ca05cb58eb03f7d7e7af1b757f6492e5f1030ad6 is the first bad commit
commit ca05cb58eb03f7d7e7af1b757f6492e5f1030ad6
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Tue Oct 5 12:00:44 2021 +0200

    source sha:03ea50373b37f2a0e5d44649a6ccc9c89d1e3244

https://git.libreoffice.org/core/+/03ea50373b37f2a0e5d44649a6ccc9c89d1e3244
  tdf#144846 launch gtk3 menubar menus from LibreOffice code
Comment 6 Duns 2022-01-29 17:52:24 UTC
then, there is something I can do, to avoid it?
Comment 7 raal 2022-01-29 18:03:29 UTC
(In reply to Duns from comment #6)
> then, there is something I can do, to avoid it?

No, the developer was notified. Hopefully he will fix it.
Comment 8 Caolán McNamara 2022-02-19 19:43:42 UTC
*** Bug 147062 has been marked as a duplicate of this bug. ***
Comment 9 Caolán McNamara 2022-04-05 07:45:15 UTC

*** This bug has been marked as a duplicate of bug 146174 ***