Bug 146813 - Crash in: SfxSetItem::GetItemSet()
Summary: Crash in: SfxSetItem::GetItemSet()
Status: RESOLVED DUPLICATE of bug 146815
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.2.4.1 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-01-17 09:13 UTC by Colin
Modified: 2022-01-17 12:19 UTC (History)
1 user (show)

See Also:
Crash report or crash signature: ["SfxSetItem::GetItemSet()"]
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Colin 2022-01-17 09:13:01 UTC
This bug was filed from the crash reporting server and is br-5dd4df5d-4fb5-4689-b80a-41db9208aa4d.
=========================================
I simplöy tried to enable advanced features AND large spreadsheets
I selected restart later after Advanced features then restart now after large spreadsheets.
I was trying to re-create a crash from a previous endeavour to utilise large spreadsheets which also crashed but I failed to record the report ID so I have no idea if this is the same crash.
I will now try to recreate the original crash in order to verify or eliminate the report
Comment 1 Colin 2022-01-17 10:42:24 UTC
Shut down and restart, Creating new blank sheet and saving it, opening existing sheet, from the task bar jump list, from a desktop shortcut or from the File>Recent Items List all produce an empty list of "the following files will be recovered" then insist on sending a crash report. I will now try safe mode option with restore from previous - which also fails.
Getting a file to load and then making minor amendments results in a crash but at least the list of files to be recovered is now populated. Unfortunately, the recovery function stalls on a full progress bar. Closing the progress bar closes the recovery procedure pane.
Recovery does not result in recovery of the changed state of the file - just the state last time it was successfully opened
Comment 2 Xisco Faulí 2022-01-17 11:28:48 UTC

*** This bug has been marked as a duplicate of bug 146815 ***
Comment 3 Colin 2022-01-17 11:29:41 UTC
Deleting & Rebuilding user profile appears to be the remedy however, the user profile WAS corrupted by enabling experimental features and large spreadsheet
Comment 4 Xisco Faulí 2022-01-17 12:11:33 UTC
(In reply to Colin from comment #3)
> Deleting & Rebuilding user profile appears to be the remedy however, the
> user profile WAS corrupted by enabling experimental features and large
> spreadsheet

No, it's not a user profile probem. When you delete the user profile, the experimental features gets disabled, thus the spreadsheets are not loaded with the large spreadsheet feature opts in.

*** This bug has been marked as a duplicate of bug 146815 ***
Comment 5 Colin 2022-01-17 12:19:53 UTC
(In reply to Xisco Faulí from comment #4)
> (In reply to Colin from comment #3)

> No, it's not a user profile probem. When you delete the user profile, the
> experimental features gets disabled, thus the spreadsheets are not loaded
> with the large spreadsheet feature opts in.
> 
> *** This bug has been marked as a duplicate of bug 146815 ***

I didn't delete the user profile until after I continually activated and deactivated the special features AND crashed about six times - I was hoping the action would clear the problem but no joy. Deleting the profile and rebuilding from scratch has fixed it for me. I can now use LO without crashing.