Bug 146896 - Suggestion on 'view' layout labels
Summary: Suggestion on 'view' layout labels
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.3.0.2 rc
Hardware: x86-64 (AMD64) All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Writer-Web-Layout
  Show dependency treegraph
 
Reported: 2022-01-21 15:27 UTC by Ryan
Modified: 2022-02-08 09:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ryan 2022-01-21 15:27:41 UTC
Description:
This is a friendly suggestion/feature request.

TL;DR
The options under 'view' > 'normal' or 'web'
should be labeled more intuitively.



Steps to Reproduce:
1. None


Actual Results:
:]

Expected Results:
:D


Reproducible: Always


User Profile Reset: Yes



Additional Info:
I have been writing docs with the 'normal' layout for several years because the 'web' option didn't ever get my attention. 
The web option is really really great if you want to focus on the content rather than what it looks like on paper.
The name 'web' makes it sound like it is only useful for publishing websites or something else.
The label 'normal' is even less informative.
 I would suggest changing the labels to something along the lines of "Paged" vs "Unbound".
Comment 1 Dieter 2022-02-05 06:10:19 UTC
Ryan, thank you for your suggestion. I added desing-team for further inputan decision.

Personally I wouldn't change the names (You have to change all documentation), but perhaps we could add some informations to LO help to make clear that creating html documents might not be the only use case.

https://help.libreoffice.org/7.3/en-GB/text/swriter/main0103.html?DbPAR=WRITER
Comment 2 Heiko Tietze 2022-02-07 15:39:08 UTC
(In reply to Ryan from comment #0)
> The name 'web' makes it sound like it is only useful for publishing websites
> or something else.

The web mode really targets HTML production, see https://help.libreoffice.org/7.3/en-US/text/swriter/01/03120000.html. If you are looking for distraction free writing mode take a look at "show whitespace" and "full screen" under view. 

My take => WF
Comment 3 Ryan 2022-02-07 16:43:41 UTC
Full screen mode still retains the pages.. what I like about the 'Web' layout - there are no page formatting distractions, so I feel it serves a different function from the 'Full screen' view.

I feel like the 'Full screen' is better for getting rid of buttons and other apps while web view gets rid of the 'bounded' paged layout.

'Show whitespace' doesn't seem to do anything on my PC.
Comment 4 Heiko Tietze 2022-02-08 09:55:42 UTC
(In reply to Ryan from comment #3)
> 'Show whitespace' doesn't seem to do anything on my PC.

https://help.libreoffice.org/7.3/en-US/text/swriter/01/show_whitespace.html


Using the Web View mode clears all layout, you could use any text editor for this purpose. The labels are easy to understand and appropriate for the task. So I'll resolve this request as WF.

Nevertheless, your request for a better distraction free writing mode is reasonable. We received some requests:
Bug 37967 - VIEWING: Option like "MS WORD's normal view" needed
Bug 53895 - Distraction-free writing extension or functionality (UI)
Bug 128349 - MUFFIN mode for context menus only, similar to full-screen but windowed
Bug 146455 - LibreOffice Writer: Focus Mode (or Literary Mode or Writers Mode)

You are very welcome to comment on these tickets.