Bug 146942 - Dropdown menus disappear in Wayland
Summary: Dropdown menus disappear in Wayland
Status: RESOLVED DUPLICATE of bug 144585
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.3.0.2 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Wayland KDE
  Show dependency treegraph
 
Reported: 2022-01-23 18:34 UTC by tim
Modified: 2022-01-25 06:18 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tim 2022-01-23 18:34:17 UTC
Description:
When I open a dropdown menu, such as font selection or font size selection, the dropdown menu appears in the center of the display for a brief moment (with the selections visible) then immediately disappears. This happens only under Wayland, if I switch to an X11 session the menus appear correctly.

Steps to Reproduce:
1. Open Writer, Calc, Impress, etc.
2. Click on a dropdown menu (font, font-size, line-color, fill-color, etc)

Actual Results:
Menu appears in center of display, then disappears immediately

Expected Results:
Menu appears at location of dropdown and disappears after selection


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 7.3.0.2 / LibreOffice Community
Build ID: 30(Build:2)
CPU threads: 4; OS: Linux 5.15; UI render: default; VCL: kf5 (cairo+wayland)
Locale: en-US (en_US.UTF-8); UI: en-US
Debian package version: 1:7.3.0~rc2-3
Calc: threaded
Comment 1 Michael Weghorn 2022-01-25 06:18:30 UTC

*** This bug has been marked as a duplicate of bug 144585 ***