Bug 147172 - Libreoffice drop-down menus not working in plasma wayland session
Summary: Libreoffice drop-down menus not working in plasma wayland session
Status: RESOLVED DUPLICATE of bug 144585
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.3.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Wayland KDE
  Show dependency treegraph
 
Reported: 2022-02-04 09:47 UTC by giors_00
Modified: 2022-04-02 18:25 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description giors_00 2022-02-04 09:47:24 UTC
Description:
Drop down menus (font, size, paragraph style...) not displaying correctly (unusable---they appear and disappear). 



Steps to Reproduce:
1.in plasma wayland session open libreoffice
2.click on font, font's size o paragraph style drop down menu
3.drop-down list not showing correctly (appears and disappears rapidly in the middle of the page)

Actual Results:
drop-down list not showing correctly (appears and disappears rapidly in the middle of the page) -- unusable

Expected Results:
drop-down menu to work just normally


Reproducible: Always


User Profile Reset: Yes



Additional Info:


Version: 7.3.0.3 / LibreOffice Community
Build ID: 30(Build:3)
CPU threads: 4; OS: Linux 5.16; UI render: default; VCL: kf5 (cairo+wayland)
Locale: es-ES (es_ES.UTF-8); UI: es-ES
7.3.0-2
Calc: threaded
Comment 1 giuseppe 2022-02-10 10:10:02 UTC
Can confirm this bug. It wasn't present with the previous build.
Comment 2 giors_00 2022-02-11 07:40:30 UTC
QT_QPA_PLATFORM=xcb seems to work as a (hopefully temporal) workaround
Comment 3 GeneC 2022-02-11 23:52:13 UTC
I see exactly same problem:
Arch Linux running plasma and wayland

libreoffice : 7.3.0
Plasma : 5.24.0
qt5-base: 5.15.2+kde+r297
Comment 4 Michael Weghorn 2022-02-17 06:19:02 UTC

*** This bug has been marked as a duplicate of bug 144585 ***
Comment 5 giors_00 2022-02-18 18:17:14 UTC
Just to confirm that the bug persists in the 

Version: 7.3.0.3 / LibreOffice Community
Build ID: 30(Build:3)
CPU threads: 4; OS: Linux 5.16; UI render: default; VCL: kf5 (cairo+wayland)
Locale: es-ES (es_ES.UTF-8); UI: es-ES
7.3.0-5
Calc: threaded
Comment 6 sal 2022-04-02 17:03:03 UTC
I have this bug too on wayland

Info:
LibreOffice version: 7.3.2.2 30(Build:2)
OS: Archlinux
DE: KDE Plasma wayland session
Comment 7 Michael Weghorn 2022-04-02 18:25:41 UTC
(In reply to sal from comment #6)
> I have this bug too on wayland
> 
> Info:
> LibreOffice version: 7.3.2.2 30(Build:2)
> OS: Archlinux
> DE: KDE Plasma wayland session

Yes, but please leave this bug here closed, since the problem is tracked in bug 144585, which is about the same problem.

*** This bug has been marked as a duplicate of bug 144585 ***