Bug 147343 - Wrong microtypography for AM/PM indicator in Spanish locales
Summary: Wrong microtypography for AM/PM indicator in Spanish locales
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: target:7.4.0 target:7.3.2
Keywords:
Depends on:
Blocks:
 
Reported: 2022-02-10 12:30 UTC by Adolfo Jayme Barrientos
Modified: 2022-02-14 06:07 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adolfo Jayme Barrientos 2022-02-10 12:30:12 UTC
https://cgit.freedesktop.org/libreoffice/core/tree/i18npool/source/localedata/data/es_ES.xml#n50

In Spanish, these are abbreviations, not acronyms, and thus should be written “a. m.” and “p. m.” instead of “AM” and “PM”. The Spanish language has a uniform, pan-region orthographic norm, so this is applicable to all locales. Please use a no-break space in between. TIA!
Comment 1 Julien Nabet 2022-02-10 16:48:55 UTC
Here's the patch:
https://gerrit.libreoffice.org/c/core/+/129793

As I indicated in comment:
"Since you talked about Spanish locales, should we do the same in source/localedata/data/an_ES.xml ?"
Comment 2 Julien Nabet 2022-02-13 08:50:24 UTC
Patch for 7.3 waiting for review here:
https://gerrit.libreoffice.org/c/core/+/129843
Comment 3 Commit Notification 2022-02-13 08:50:28 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/d582bc9735022996a317ed661388621edabf78cc

tdf#147343: Wrong typo for AM/PM indicator in Spanish locales

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2022-02-14 06:07:01 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/b651275e76ec41e2802cb1a558d9fd90b73ef6c7

tdf#147343: Wrong typo for AM/PM indicator in Spanish locales

It will be available in 7.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.