Bug 147394 - Chart - Delete Legend: crash
Summary: Chart - Delete Legend: crash
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.4.0.0 alpha0+ Master
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.4.0
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2022-02-12 18:37 UTC by BogdanB
Modified: 2022-02-14 16:29 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
demo document (12.66 KB, application/vnd.oasis.opendocument.spreadsheet)
2022-02-12 18:38 UTC, BogdanB
Details
bt with debug symbols (1.59 KB, text/plain)
2022-02-12 20:38 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description BogdanB 2022-02-12 18:37:49 UTC
Description:
When you delete the Legend from ant Chart LibreOffice crash.

Regression

Steps to Reproduce:
1. Open the file. Try to delete chart Legend
2. Crash


Actual Results:
Crash

Expected Results:
NO Crash


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 1c0aa970650ffc7c749e0b5ea655ebb2d137c8ae
CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded
Comment 1 BogdanB 2022-02-12 18:38:46 UTC
Created attachment 178242 [details]
demo document

Could be reproduce with any chart/any file. The file is just as a demo document.
Comment 2 Julien Nabet 2022-02-12 20:38:20 UTC
Created attachment 178246 [details]
bt with debug symbols

On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 3 Julien Nabet 2022-02-12 20:43:23 UTC
Regression from: 63e8c2ccd39263b24f644c3d0394044a2613eb88
use more concrete types in chart2, Diagram

(I reverted it locally, I don't reproduce the crash).

Noel: thought you might be interested in this one.
Comment 4 BogdanB 2022-02-13 17:34:48 UTC
Also, could be related to this bug: if I insert in the chart an Axis Title and try to delete it LibreOffice is freezing or I am getting a crash, similar to that of Legend.
Comment 5 BogdanB 2022-02-13 17:37:45 UTC
Interesting, if I delete the Legend with right click when in edit mode in a chart NO CRASH. Just when click on Legend and delete I get a crash.
Comment 6 Commit Notification 2022-02-13 18:48:43 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/11a3e5707d6b524728b24e170eb542bba273d811

tdf#147394 delete crash legend

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 BogdanB 2022-02-13 20:46:06 UTC
Thanks Noel.
Very fast fixing.
24 hours and 11 minutes between the report filled until it was solved.
Comment 8 BogdanB 2022-02-14 13:40:17 UTC
Noel, This bug is fixed. Verified with
Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 2f0c26dc83448a934af5383f9f6b7a607c334744
CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: gtk3
Locale: ro-RO (ro_RO.UTF-8); UI: en-US
Calc: threaded


But, what I notice, there are many crashes with simple charts, that I could not reproduce each time, like:
Insert 
A  B
1  2
2  3

in a new Calc and generate a chart. Try to insert Axis Title and delete it. And again and again. Could get you a crash sometimes.

Also I get a crash when tring to insert a Legend in a chart without one.
If you can play a little with new documents with simple data and inserting a default chart and trying to insert/delete some elements into a chart. If I could get a constant crash I will come with a new report.

Thansk for your work.
Comment 9 Commit Notification 2022-02-14 16:29:53 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/b05f2e0f3117ed59f63d97cebeb7ea7372df8ed5

tdf#147394: sc: Add UItest

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.