Bug 147402 - Applying spelling suggestion adds the word behind the existing one if Track Changes Record enabled
Summary: Applying spelling suggestion adds the word behind the existing one if Track C...
Status: RESOLVED DUPLICATE of bug 146435
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.1.0.3 release
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-02-13 13:13 UTC by Telesto
Modified: 2022-04-06 12:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file (8.66 KB, application/vnd.oasis.opendocument.text)
2022-02-13 13:13 UTC, Telesto
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2022-02-13 13:13:28 UTC
Description:
Applying spelling suggestion adds the word behind the existing one if Track Changes Record enabled 

Steps to Reproduce:
1. Open the attached file
2. Assuming Dictionary installed (in this case german)
3. Automatic spell checking on
4. Right click the yellow marked word (doesn't really matter, but well)
5. Replace with Voila 

Actual Results:
Oilyvoila

Expected Results:
Voila


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 42c5506a9e9ef58efd8193a193464e3b49d481ca
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

and in
7.1

not in
7.0
Comment 1 Telesto 2022-02-13 13:13:40 UTC
Created attachment 178254 [details]
Example file
Comment 2 Gabor Kelemen (allotropia) 2022-02-15 08:55:13 UTC

*** This bug has been marked as a duplicate of bug 146435 ***
Comment 3 Telesto 2022-03-13 18:32:29 UTC
Still present 
Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 3ccc4c123f5e78e0204d11abeab2d1a74278ca3e
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 4 Telesto 2022-03-13 18:34:05 UTC
(In reply to Gabor Kelemen (allotropia) from comment #2)
> 
> *** This bug has been marked as a duplicate of bug 146435 ***

FWIW did you bibisect it to the commit of bug 146435 or simply a guess?
Comment 5 Telesto 2022-04-06 12:04:58 UTC

*** This bug has been marked as a duplicate of bug 146435 ***