Bug 147414 - Space is add after the cursor not before (so cursor doesn't move when pressing space) with track & changed enabled
Summary: Space is add after the cursor not before (so cursor doesn't move when pressin...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All All
: medium normal
Assignee: Michael Stahl (allotropia)
URL:
Whiteboard: target:7.4.0 target:7.3.3 target:7.2.7
Keywords: bibisected, bisected, regression
: 147486 (view as bug list)
Depends on:
Blocks: redlinehide-regressions
  Show dependency treegraph
 
Reported: 2022-02-14 14:41 UTC by Telesto
Modified: 2022-08-10 21:51 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2022-02-14 14:41:15 UTC
Description:
Space is add after the cursor not before (so cursor doesn't move when pressing space) with track & changed enabled

Steps to Reproduce:
1. Open attachment 178254 [details]
2. Place cursor after oily (yellow)
3. Toggle formatting marks on
4. Press backspace once
5. Press space.. 

Actual Results:
Cursor doesn't move along with space (space is added, though)

Expected Results:
The space is entered before the cursor not after the cursor


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 42c5506a9e9ef58efd8193a193464e3b49d481ca
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

and in
6.2 

Not in
Version: 6.1.0.0.beta1+
Build ID: da49f4aeb8d5e9a7d2cba8855d911e7cc1d2f1e2
CPU threads: 4; OS: Windows 6.3; UI render: default; 
Locale: nl-NL (nl_NL); Calc: CL
Comment 1 Telesto 2022-02-14 14:46:13 UTC
Hmm, well apparently fixed somewhere and broken again'
Found in
Version: 7.3.0.0.alpha1+ (x64) / LibreOffice Community
Build ID: 7b0aabe71d2455f6f643553a07f1056935cf190f
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL

but not in
Version: 7.2.1.0.0+ (x64) / LibreOffice Community
Build ID: 8fdbb8aed1b48734a717d5f98ada566de7204605
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 2 Telesto 2022-02-15 09:42:22 UTC
Another weird side-effect

1. Open attachment 178254 [details]
2. Place cursor after oily (yellow)
3. Press backspace
4. Press space (nothing moving)
5. Type a letter -> Whole part after oily becomes yellow highlighted
Comment 3 Gabor Kelemen (allotropia) 2022-02-16 21:30:22 UTC
Confirming in
Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 11a3e5707d6b524728b24e170eb542bba273d811
CPU threads: 14; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: en-US (hu_HU); UI: en-US
Calc: threaded

Bibisected with win-6.3 to:

https://git.libreoffice.org/core/+/32902f66e7749b2d06d13f50416be5323a0c0ea9

author	Michael Stahl <Michael.Stahl@cib.de>	Fri Nov 30 17:54:41 2018 +0100
committer	Michael Stahl <Michael.Stahl@cib.de>	Tue Dec 18 17:55:30 2018 +0100

sw_redlinehide: make layout based Show/Hide mode the default

Adding CC to: Michael Stahl

Can't confirm this got better in 7.2: for me it looks to be broken there too.
Comment 4 Gabor Kelemen (allotropia) 2022-02-16 21:35:01 UTC
(In reply to Telesto from comment #2)
> Another weird side-effect
> 
> 1. Open attachment 178254 [details]
> 2. Place cursor after oily (yellow)
> 3. Press backspace
> 4. Press space (nothing moving)
> 5. Type a letter -> Whole part after oily becomes yellow highlighted

I can reproduce this with different steps:

1, open the example file
2, place cursor after oily (yellow)
3, Press Delete to remove the space
3, Press Backspace to remove y
4, Press Space
5, Press a letter -> rest of the text becomes yellow.

This also started with the above commit, but likely a separate issue.
Comment 5 Telesto 2022-02-16 22:04:01 UTC
(In reply to Gabor Kelemen (allotropia) from comment #4)
Many Thanks for bibisect, however it should have been done with experimental mode on to bibisect the exact commit. 

I should have mentioned that... sorry
Comment 6 Telesto 2022-02-17 15:41:11 UTC
@Xisco
Regarding to importance. This does make Track Changes pretty unreliable/unbearable  to use, for people editing text with track changes on. And might a source for crashes too. See bug 147332 (unconfirmed)

I admit it's pretty surprising it took this long for an actual bug report .. so apparently track & changes isn't used that often..
Comment 7 Gabor Kelemen (allotropia) 2022-02-17 21:02:19 UTC
Seems to have started in 6.3 with:

https://git.libreoffice.org/core/+/9926ea7dd07f1f3d012ddf97941a42bb7fa5717d

author	Michael Stahl <Michael.Stahl@cib.de>	Wed Nov 28 15:51:02 2018 +0100
committer	Michael Stahl <Michael.Stahl@cib.de>	Sat Dec 01 08:44:45 2018 +0100

sw_redlinehide_4a: SwAutoCorrDoc iterates frames, not nodes
Comment 8 Commit Notification 2022-03-07 20:12:02 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e2076b31a91d3882f3deeaa5d3d4659da0e4b17c

tdf#147414 sw_redlinehide: fix cursor position after AutoCorrect

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Michael Stahl (allotropia) 2022-03-07 20:13:10 UTC
fixed on master
Comment 10 Commit Notification 2022-03-10 09:32:42 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/ab0756c1b7509a034d0bb74251c519a090dedc7c

tdf#147414 sw_redlinehide: fix cursor position after AutoCorrect

It will be available in 7.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2022-03-10 09:35:46 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/8e63eb272ca0a75b2e800a63c47cf491715587a9

tdf#147414 sw_redlinehide: fix cursor position after AutoCorrect

It will be available in 7.2.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Michael Stahl (allotropia) 2022-05-17 13:43:59 UTC
*** Bug 147486 has been marked as a duplicate of this bug. ***
Comment 13 Gabor Kelemen (allotropia) 2022-08-10 21:51:35 UTC
Verified in

Version: 7.4.0.0.beta1+ (x64) / LibreOffice Community
Build ID: 3c4acc718549ab027be5465d60c8d5a0e3b8feaa
CPU threads: 14; OS: Windows 10.0 Build 19044; UI render: default; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: threaded

Cursor moves correctly. Issue in comment #4 is also solved.