Bug 147439 - AutoFilter: "Search items" text box losing focus unexpectedly since 7.3
Summary: AutoFilter: "Search items" text box losing focus unexpectedly since 7.3
Status: RESOLVED DUPLICATE of bug 146326
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.3.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2022-02-15 13:07 UTC by Rafael Lima
Modified: 2022-03-01 16:03 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Video showing the behavior in Calc 7.3.0 (270.57 KB, video/mp4)
2022-02-15 13:07 UTC, Rafael Lima
Details
Video showing the behavior in Calc 7.2.5 (172.34 KB, video/mp4)
2022-02-15 13:12 UTC, Rafael Lima
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Lima 2022-02-15 13:07:32 UTC
Created attachment 178282 [details]
Video showing the behavior in Calc 7.3.0

Up to LO 7.2.5, when you open the AutoFilter dropdown dialog, the "Search Items" text box received focus and you could type even if you moved the mouse over the UI. The text box retained focus, which is very important because most users open this drop-down and start typing what they're looking for.

However, since 7.3.0 there was an important change. When the user opens the drop down dialog, the text box has focus. But as soon as the mouse moves over the UI, the textbox loses focus and the user can no longer type anything (See attached video). Notice that when I click the search box and move the mouse up (or down), it loses focus. This was not the case in LO 7.2.5.

As a frequent user of the AutoFilter feature, I consider this to be an important regression, which has hindered my productivity in LO Calc. This makes me have to keep clicking the search box to regain focus and taking care to not move the mouse.
Comment 1 Rafael Lima 2022-02-15 13:12:01 UTC
Created attachment 178283 [details]
Video showing the behavior in Calc 7.2.5

Here's the behavior we get in 7.2.5. The search box does not lose focus with mouse movement.

Moreover, in LO 7.4 this is an issue when we move the mouse up (not down).

System info:

Version: 7.3.0.3 / LibreOffice Community
Build ID: 30(Build:3)
CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Ubuntu package version: 1:7.3.0~rc3-0ubuntu0.21.10.1~lo1
Calc: threaded

Version: 7.2.5.2 / LibreOffice Community
Build ID: 499f9727c189e6ef3471021d6132d4c694f357e5
CPU threads: 16; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+xcb)
Locale: pt-BR (pt_BR.UTF-8); UI: en-US
Calc: threaded
Comment 2 m.a.riosv 2022-02-15 16:03:27 UTC
Repro
Version: 7.3.0.3 (x64) / LibreOffice Community
Build ID: 0f246aa12d0eee4a0f7adcefbf7c878fc2238db3
CPU threads: 4; OS: Windows 10.0 Build 21390; UI render: Skia/Vulkan; VCL: win
Locale: es-ES (es_ES); UI: en-US Calc: CL
Comment 3 Roman Kuznetsov 2022-02-15 22:17:17 UTC
I bisected this one in win64-7.4 bisect repo and got a SHA
 29145df0977baa866e7da94d1d385b772ae1e6ce

https://gerrit.libreoffice.org/c/core/+/126209

https://git.libreoffice.org/core/commit/29145df0977baa866e7da94d1d385b772ae1e6ce

Added to CC: Caolán McNamara

Caolán could you please look at it? Thanks
Comment 4 Kevin Suo 2022-03-01 11:41:21 UTC

*** This bug has been marked as a duplicate of bug 146326 ***