Bug 147486 - Text highlight attribute applied to pre-existing tracked change
Summary: Text highlight attribute applied to pre-existing tracked change
Status: RESOLVED DUPLICATE of bug 147414
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.0.4 release
Hardware: All All
: medium normal
Assignee: Michael Stahl (allotropia)
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: redlinehide-regressions
  Show dependency treegraph
 
Reported: 2022-02-17 07:39 UTC by Gabor Kelemen (allotropia)
Modified: 2022-05-17 13:43 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen (allotropia) 2022-02-17 07:39:07 UTC
This is split from bug 147414

1. Open attachment 178254 [details]
2, Place cursor after oily (yellow)
3, Press Delete to remove the space
3, Press Backspace to remove y
4, Press Space
5, Press a letter -> rest of the text becomes yellow.

Bibisected with win-6.3 to:

https://git.libreoffice.org/core/+/32902f66e7749b2d06d13f50416be5323a0c0ea9

author	Michael Stahl <Michael.Stahl@cib.de>	Fri Nov 30 17:54:41 2018 +0100
committer	Michael Stahl <Michael.Stahl@cib.de>	Tue Dec 18 17:55:30 2018 +0100

sw_redlinehide: make layout based Show/Hide mode the default

Adding CC to: Michael Stahl
Comment 1 Gabor Kelemen (allotropia) 2022-02-17 21:37:48 UTC
Bibisected with 6.2 to:

https://git.libreoffice.org/core/+/def855d05efeb711e246663c37add218aaadac2f

author	Michael Stahl <Michael.Stahl@cib.de>	Wed Sep 12 10:44:38 2018 +0200
committer	Michael Stahl <Michael.Stahl@cib.de>	Wed Sep 19 10:18:31 2018 +0200

sw_redlinehide_2: view cursor movement, SwCursorShell::LeftRight()
Comment 2 raal 2022-02-20 05:35:41 UTC
Confirm with Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 8942956e05f2208ffb666a2118f5db092c30ce6a
CPU threads: 4; OS: Linux 5.11; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded Jumbo
Comment 3 Michael Stahl (allotropia) 2022-05-17 13:43:59 UTC
was fixed by e2076b31a91d3882f3deeaa5d3d4659da0e4b17c

*** This bug has been marked as a duplicate of bug 147414 ***