Bug 147641 - OPTIONS DIALOG: Configuring default font size for captions always reset to 12 points
Summary: OPTIONS DIALOG: Configuring default font size for captions always reset to 12...
Status: VERIFIED DUPLICATE of bug 136098
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.3.6.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: target:7.4.0 target:7.3.3 target:7.2.7
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Options-Dialog-Writer Caption
  Show dependency treegraph
 
Reported: 2022-02-24 15:15 UTC by philippe
Modified: 2022-05-09 10:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description philippe 2022-02-24 15:15:09 UTC
When displaying options-Writer-default font (unsure of the text, mine is in French), changing the font for "Legend" keeps resetting to 12points
Comment 1 Dieter 2022-03-09 15:36:07 UTC
Thank you for reporting the bug. Could you please try to reproduce it with the latest version of LibreOffice from https://www.libreoffice.org/download/libreoffice-fresh/ ? I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' if the bug is still present in the latest version. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 2 philippe 2022-03-10 09:33:59 UTC
I've tested with the last version 7.3.1.3
I open Tools->Options->LibreOfficeWriter->Standard fonts (remember I'm in French, I assume this is the entry)and change the size of Legend font from 12 points to anything else, I save by pressing OK, I reopen the same window the font size is still 12 points.
I set the bug to UNCONFIRMED as you indicated.
Comment 3 Dieter 2022-03-13 10:34:56 UTC
I don't have font "Legend" but I've tested with Liberation Serif and couldn't reproduce. Does it happen with every font? Are you also able to reproduce it in SafeMode (Help -> Restart in SafeMode)?
=> NEEDINFO
Comment 4 philippe 2022-03-13 16:02:34 UTC
(In reply to Dieter from comment #3)
> I don't have font "Legend" but I've tested with Liberation Serif and
> couldn't reproduce. Does it happen with every font? Are you also able to
> reproduce it in SafeMode (Help -> Restart in SafeMode)?
> => NEEDINFO

There must be s misunderstandanding. Legen is not a font but on option in the dialog window.
If you open the menu Tools->Options->LibreOfficeWriter->Standard fonts you will find "by default", "Title", "List", "Index" AND "Legend". Changing this one (not tested all of them) doesn't work.

=> UNCONFIRMED
Comment 5 Dieter 2022-03-13 16:17:01 UTC
(In reply to philippe from comment #4)
> There must be s misunderstandanding. Legen is not a font but on option in
> the dialog window.
> If you open the menu Tools->Options->LibreOfficeWriter->Standard fonts you
> will find "by default", "Title", "List", "Index" AND "Legend". Changing this
> one (not tested all of them) doesn't work.

Ah, it's about captions!

I confirm it with

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 51fb84829afbc1c0957fd1a489085613ad199f1a
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Steps to reproduce
1. Open Tools -> Options -> LibreOfficeWriter -> Basic Fonts (Western)
2. Change font size for captions to 16pt -> O.K.
3. Open dialog again

Actual result:
Default font size for caption (12pt)

Expected result:
16 pt
Comment 6 Dieter 2022-03-13 16:26:16 UTC
Also present in

Version: 7.0.6.2 (x64)
Build ID: 144abb84a525d8e30c9dbbefa69cbbf2d8d4ae3b
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL

and in

Version: 6.3.6.2 (x64)
Build-ID: 2196df99b074d8a661f4036fca8fa0cbfa33a497
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: de-DE (de_DE); UI-Sprache: de-DE
Calc: CL

but not in

Version: 6.1.6.3 (x64)
Build-ID: 5896ab1714085361c45cf540f76f60673dd96a72
CPU-Threads: 4; BS: Windows 10.0; UI-Render: GL; 
Gebietsschema: de-DE (de_DE); Calc: CL
Comment 7 raal 2022-03-19 19:45:37 UTC
This seems to have begun at the below commit.
Adding Cc: to Noel Grandin ; Could you possibly take a look at this one?
Thanks
 15ca471a7c629e7eb27254fbe371bd2f1ebcc2ac is the first bad commit
commit 15ca471a7c629e7eb27254fbe371bd2f1ebcc2ac
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Fri Nov 9 14:52:01 2018 +0100

    source sha:65d2d2647ead42e5bbb7800f14c047f383fe450b

https://git.libreoffice.org/core/+/65d2d2647ead42e5bbb7800f14c047f383fe450b
  loplugin:singlevalfields in sw
Comment 8 Commit Notification 2022-03-23 17:20:12 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/323ff2749b6be5f6ef98c6250afce4fa89e3aa1c

tdf#147641 default font size for captions always reset

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2022-03-24 03:22:47 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/cd39085292b3c43d6e437957109fde63fbcb15d4

tdf#147641 default font size for captions always reset

It will be available in 7.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2022-03-24 03:22:58 UTC
Noel Grandin committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/11f22ac8526557c3340aa948da12ac3da81cda7e

tdf#147641 default font size for captions always reset

It will be available in 7.2.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Dieter 2022-04-10 10:12:25 UTC
VERIFIED with

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: d34d1db55978bdcff082af1e0f75b18fa6fc94f4
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Noel, thanks for fixing it!
Comment 12 Timur 2022-05-09 10:27:23 UTC
Really thanks to Noel. 
But Dieter, please search before confirming the bug, you already was in CC. 

Also, if you are not interested in the bug anymore, please don't remove from CC list as it sends mails and updates the bug, rather just tick "never email me".

*** This bug has been marked as a duplicate of bug 136098 ***