Bug 147686 - Colibre: Text direction icons (right to left and left to right) have less clear arrows especially on large screens (1920x1080)
Summary: Colibre: Text direction icons (right to left and left to right) have less cle...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Rizal Muttaqin
URL:
Whiteboard: target:7.3.2 target:7.4.0 target:7.2.7
Keywords:
Depends on:
Blocks: Icon-Theme-Colibre
  Show dependency treegraph
 
Reported: 2022-02-27 13:36 UTC by Rizal Muttaqin
Modified: 2022-02-27 22:04 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Text direction icon with Colibre theme (33.48 KB, image/png)
2022-02-27 13:36 UTC, Rizal Muttaqin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rizal Muttaqin 2022-02-27 13:36:18 UTC
Created attachment 178566 [details]
Text direction icon with Colibre theme

Using Colibre theme, the arrow in Left-to-Right or Right-to-Left have less visibility if we do a quick scan they are too big and crash into paragraph symbols. Even using 32 px size icon. While 16 px size have clearer one.

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: ea25606de5f1a60430a74107b0e2e0986ac1bb15
CPU threads: 8; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+xcb)
Locale: id-ID (id_ID.UTF-8); UI: en-US
Calc: threaded
Comment 1 Rizal Muttaqin 2022-02-27 13:43:33 UTC
Sorry the issue is just appear in 24 px icon size
Comment 2 Commit Notification 2022-02-27 21:42:28 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/ba60c8f35d053847fec0a34c8783641ed993e8bc

Colibre: tdf#147686 Fix arrow of Text Direction icons (large size)

It will be available in 7.3.2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2022-02-27 21:42:38 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/53b11d3fe61b64b5a996a10d2d0491626c7fc5e4

Colibre: tdf#147686 Fix arrow of Text Direction icons (large size)

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2022-02-27 21:42:48 UTC
Rizal Muttaqin committed a patch related to this issue.
It has been pushed to "libreoffice-7-2":

https://git.libreoffice.org/core/commit/32f94f26099509cff1ae7f9f2c85787d3373c83d

Colibre: tdf#147686 Fix arrow of Text Direction icons (large size)

It will be available in 7.2.7.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.