Bug 147723 - CRASH: after pasting twice
Summary: CRASH: after pasting twice
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.4.0.0 alpha0+ Master
Hardware: All All
: medium normal
Assignee: Michael Stahl (allotropia)
URL:
Whiteboard: target:7.4.0 target:7.3.3
Keywords: bibisected, bisected, regression
: 147725 (view as bug list)
Depends on:
Blocks:
 
Reported: 2022-03-02 09:21 UTC by Xisco Faulí
Modified: 2022-04-27 18:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2022-03-02 09:21:05 UTC
Steps to reproduce:
1. Open attachment 173210 [details] from bug 142759
2. Select all
3. Copy
4. Paste
5. Paste

-> Crash

Reproduced in

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: c97a3592c78ce276a353f95ce68c70a8a39174a0
CPU threads: 8; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: es-ES (es_ES.UTF-8); UI: en-US
Calc: threaded
Comment 1 Xisco Faulí 2022-03-02 09:21:58 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=d11fb6cecaf72787973990e09cc7e8d03bdbf9d7

author	Michael Stahl <michael.stahl@allotropia.de>	2021-12-22 16:52:28 +0100
committer	Michael Stahl <michael.stahl@allotropia.de>	2021-12-23 09:11:20 +0100
commit d11fb6cecaf72787973990e09cc7e8d03bdbf9d7 (patch)
tree f014c706d253a892ca3ccd48f2cc5634d2a17340
parent 763c2a436baa1814d2bf95477b9d79fa3934d5e5 (diff)
tdf#138771 sw_fieldmarkhide: fix overlaps in SwScriptInfo::InitScriptInfo()

Bisected with: bibisect-linux64-7.4

Adding Cc: to Michael Stahl
Comment 2 Commit Notification 2022-04-20 14:56:15 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/2f726fa41cbd249f2fb30222b29d5f30bce52e6e

tdf#147723 sw_fieldmarkhide: fix crash when copying multiple fieldmarks

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Michael Stahl (allotropia) 2022-04-20 15:32:04 UTC
fixed on master
Comment 4 Michael Stahl (allotropia) 2022-04-21 11:52:28 UTC
*** Bug 147725 has been marked as a duplicate of this bug. ***
Comment 5 Xisco Faulí 2022-04-21 11:56:27 UTC
Verified in a local build.
@Michael, thanks for fixing this issue!
Comment 6 Commit Notification 2022-04-21 11:57:15 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/93234133477d5f3268ffd441b1e2b7758c809dd4

tdf#147723 sw_fieldmarkhide: fix crash when copying multiple fieldmarks

It will be available in 7.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2022-04-21 15:03:43 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/e31cf19e5f5bcdc9e96d1ecd896a611ea035a934

tdf#147723: sw_uiwriter5: Add unittest

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2022-04-26 09:10:17 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-3-3":

https://git.libreoffice.org/core/commit/46268343a49b8c14f89b3ef0a2f1f4260ff7a490

tdf#147723 sw_fieldmarkhide: fix crash when copying multiple fieldmarks

It will be available in 7.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.