Bug 147745 - LibreOffice draw color pickers unusable on Wayland (KDE Plasma, at least)
Summary: LibreOffice draw color pickers unusable on Wayland (KDE Plasma, at least)
Status: RESOLVED DUPLICATE of bug 144585
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-03-03 13:57 UTC by Emilio Cobos Álvarez (:emilio)
Modified: 2022-03-03 15:05 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screen recording. (11.38 MB, video/x-matroska)
2022-03-03 13:58 UTC, Emilio Cobos Álvarez (:emilio)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emilio Cobos Álvarez (:emilio) 2022-03-03 13:57:06 UTC
Description:
Using the "Fill color" or "Line color" pickers in LibreOffice draw is impossible on Wayland. The picker opens in the middle of the screen, and it gets insta-closed.

Steps to Reproduce:
1. Open draw (blank document works)
2. Try to change the fill color by clicking the down arrow.

Actual Results:
Popup opens in the middle of the screen and instantly closes (if it opens at all).

Expected Results:
Popup opens and you can select a color like in X11.


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 7.3.0.3
Build ID: 30(Build:3)
CPU threads: 128; OS: Linux 5.17; UI render: default; VCL: kf5 (cairo+wayland)
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded
Comment 1 Emilio Cobos Álvarez (:emilio) 2022-03-03 13:58:27 UTC
Created attachment 178642 [details]
Screen recording.
Comment 2 Buovjaga 2022-03-03 15:05:14 UTC

*** This bug has been marked as a duplicate of bug 144585 ***