Bug 147757 - Inserting a caption does not account for rotation in choice of dimensions
Summary: Inserting a caption does not account for rotation in choice of dimensions
Status: RESOLVED DUPLICATE of bug 115463
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.4.0.0 alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Caption
  Show dependency treegraph
 
Reported: 2022-03-04 07:35 UTC by Eyal Rozenberg
Modified: 2022-03-21 08:14 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Document for reproducing the bug (316.86 KB, application/vnd.oasis.opendocument.text)
2022-03-04 07:41 UTC, Eyal Rozenberg
Details
Screenshot of invalid result of adding the caption (190.08 KB, image/png)
2022-03-04 07:42 UTC, Eyal Rozenberg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eyal Rozenberg 2022-03-04 07:35:09 UTC
If I have a floating image at the side of a paragraph of text, and I add a (no-category) caption - instead of the caption extending the area from which the image excludes the surrounding text, it extends it horizontally, and vertically at the bottom, but detracts from it at the top somehow, causing text to flow under the new frame/rectangle created by adding the caption.

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: fb9270b238cba4f36e595c5d7f4d85f6f3f18e1c
CPU threads: 4; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: en-IL (en_IL); UI: en-US
Comment 1 Eyal Rozenberg 2022-03-04 07:41:55 UTC
Created attachment 178648 [details]
Document for reproducing the bug

To reproduce:

1. Open the attached document, 147757.odt
2. Select the image.
3. On the menus, choose Insert | Caption .
4. Don't change any settings, just press Ok.

Expected: Frame/rectangle covers entire image and a bit more.
Actual: Frame/rectangle fails to cover the top of the image, text now flows under the image where it didn't use to.
Comment 2 Eyal Rozenberg 2022-03-04 07:42:53 UTC
Created attachment 178649 [details]
Screenshot of invalid result of adding the caption

Screenshot of the state of the document after following the reproduction instructions.
Comment 3 Dieter 2022-03-20 10:06:29 UTC
I confirm it with

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 51fb84829afbc1c0957fd1a489085613ad199f1a
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

But I can't confirm it with a different image. Can you test with a differnet one?
Comment 4 Eyal Rozenberg 2022-03-20 19:50:31 UTC
(In reply to Dieter from comment #3)
> But I can't confirm it with a different image. Can you test with a differnet
> one?

Ah, I know what it is. It's the fact that the image is _rotated_.

If you change the image's angle to 0, then insert the caption - its area should be ok. @Dieter, can you verify this?
Comment 5 Dieter 2022-03-21 07:17:38 UTC
(In reply to Eyal Rozenberg from comment #4)
> Ah, I know what it is. It's the fact that the image is _rotated_.

I think it's a duplicate of bug 115463. Feel free to change it back to NEW with a short reasoning, if you disagree.

*** This bug has been marked as a duplicate of bug 115463 ***
Comment 6 Eyal Rozenberg 2022-03-21 08:14:43 UTC
(In reply to Dieter from comment #5)
> I think it's a duplicate of bug 115463. Feel free to change it back to NEW
> with a short reasoning, if you disagree.

It might be a duplicate, but here we don't have this cropping of the image. Ok, let it be a dupe, although I'm not sure solving that will also solve this.