Bug 147764 - Word selection error in Arabic text
Summary: Word selection error in Arabic text
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.3.0.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: Selection RTL-Arabic-and-Farsi
  Show dependency treegraph
 
Reported: 2022-03-04 15:38 UTC by mustafa
Modified: 2022-07-17 01:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
a file (13.07 KB, application/vnd.oasis.opendocument.text)
2022-03-04 15:39 UTC, mustafa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mustafa 2022-03-04 15:38:16 UTC
Description:
Description:
Word selection error in Arabic text.

The selection error in Arabic texts has been fixed, but the word selection does not occur when justified to the left.
It used to be possible.
In previous versions this was possible.

Version: 7.1.6.2 : no error / okay super
Version: 7.3.0.3 : error
Version: 7.3.1.3 : error


Linux Mint 20.3 Cinnamon
Kernel 5.4.0-97-generic
AMD Ryzen 3 2200G with Radeon Vega Graphics × 4
Advanced Micro Devices, Inc.
AMD/ATI] Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series]

Actual Results:
the error continues

Expected Results:
the error continues


Reproducible: Always


User Profile Reset: No



Additional Info:
the error continues
Comment 1 mustafa 2022-03-04 15:39:14 UTC
Created attachment 178654 [details]
a file
Comment 2 Dieter 2022-03-20 11:02:44 UTC
I confirm it with

Version: 7.3.2.1 (x64) / LibreOffice Community
Build ID: 0b2e59a88b7e225b655db87910f97dca7aef27aa
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

Steps to reproduce
1. Open attachment 178654 [details]
2. Try to select a word (double-click) in a paragraph with more than one Arabic word. => Not possible at all
3. Try to select first left word with touchpad => only possible by dragging from right to the left)
4. Try to select a word in middle of paragraph with touchpad => not possible at all)

Not present in

Version: 7.0.6.2 (x64)
Build ID: 144abb84a525d8e30c9dbbefa69cbbf2d8d4ae3b
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL
Comment 3 raal 2022-03-23 16:56:32 UTC
Please can you test it with dev version? Looks fixed in Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 4a46a74a3de0ac7df5d3ce949dda5e809c1729ab
CPU threads: 4; OS: Linux 5.13; UI render: default; VCL: gtk3
Locale: cs-CZ (cs_CZ.UTF-8); UI: en-US
Calc: threaded Jumbo

You can download it here: http://dev-builds.libreoffice.org/daily/master/
Possible duplicate of bug 147143
Thank you
Comment 4 Aron Budea 2022-06-11 14:27:40 UTC
I can confirm this bug existed in 7.3.0.3, and is fixed in 7.3.2.2. Let's close as WFM.