Bug 147777 - Dropdown menus open in the middle of screen and immediately close or does not open at all
Summary: Dropdown menus open in the middle of screen and immediately close or does not...
Status: RESOLVED DUPLICATE of bug 144585
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.3.1.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Wayland
  Show dependency treegraph
 
Reported: 2022-03-05 05:23 UTC by AJ B
Modified: 2022-04-07 08:27 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description AJ B 2022-03-05 05:23:58 UTC
Description:
Clicking on a drapdown menu (e.g. fonts or font size) causes the menu to open in the center of the screen and close almost immediately. Often, clicking the dropdown menu to open it up does nothing at all.

Steps to Reproduce:
1. Click on a dropdown menu, such as the font selector or the text style

Actual Results:
Either the dropdown menu fails to open (most common occurance), or the dropdown menu appears in the center of the screen and immediately closes.

Expected Results:
The dropdown menu should have dropped down and remained open until either dismissed or the user makes their selection.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Version: 7.3.1.3 / LibreOffice Community
Build ID: 30(Build:3)
CPU threads: 8; OS: Linux 5.16; UI render: default; VCL: kf5 (cairo+wayland)
Locale: en-US (en_US.UTF-8); UI: en-US
7.3.1-1
Calc: threaded
Comment 1 Dieter 2022-03-20 11:24:42 UTC
I can't confirm with

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 51fb84829afbc1c0957fd1a489085613ad199f1a
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-GB
Calc: CL

I can only see, that if you have selected a dropdown list and click into another list, two clicks are needed (doesn't occur, if focus is in text area). Personally I can think of an improvement here.
Comment 2 Jiri Slaby 2022-04-07 06:34:43 UTC
This is a mee too. I can replicate using automatic filters in calc, this appears on console every time I click on the filter button:
This plugin supports grabbing the mouse only for popup windows
This plugin supports grabbing the mouse only for popup windows
qt.qpa.wayland: Wayland does not support QWindow::requestActivate()
qt.qpa.wayland: Wayland does not support QWindow::requestActivate()

$ rpm -q libreoffice kwin5
libreoffice-7.3.2.1-3.2.x86_64
kwin5-5.24.4-1.1.x86_64

Version: 7.3.2.1 / LibreOffice Community
Build ID: 30(Build:1)
CPU threads: 4; OS: Linux 5.17; UI render: default; VCL: kf5 (cairo+wayland)
Locale: cs-CZ (cs_CZ.UTF-8); UI: cs-CZ
Calc: threaded

The workaround:
QT_QPA_PLATFORM=xcb libreoffice

I.e. use Xwayland, not wayland.

(In reply to Dieter from comment #1)
> I can't confirm with
> 
> Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community

I cannot find a 7.4 alpha rpm anywhere to test...
Comment 3 Dieter 2022-04-07 07:57:46 UTC
(In reply to Jiri Slaby from comment #2)
> This is a mee too. I can replicate using automatic filters in calc

=> Status NEW

Perhaps duplicate of bug 123972
Comment 4 Michael Weghorn 2022-04-07 08:27:00 UTC
The issue w/ broken popup menus with kf5 on Wayland was just fixed, s. tdf#144585.

*** This bug has been marked as a duplicate of bug 144585 ***