Bug 147852 - FILEOPEN PPTX Master textbox with "Slide background fill" is not transparent
Summary: FILEOPEN PPTX Master textbox with "Slide background fill" is not transparent
Status: RESOLVED DUPLICATE of bug 128150
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.2.0.4 release
Hardware: All All
: medium normal
Assignee: Samuel Mehrbrodt (allotropia)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: PPTX-MasterSlide
  Show dependency treegraph
 
Reported: 2022-03-08 20:19 UTC by Gabor Kelemen (allotropia)
Modified: 2022-06-21 09:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example file from PP (37.89 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2022-03-08 20:19 UTC, Gabor Kelemen (allotropia)
Details
The example file in PP 2013 and current master in Master slide view (247.85 KB, image/png)
2022-03-08 20:20 UTC, Gabor Kelemen (allotropia)
Details
The example file in PP 2013 and current master in slide edit view (134.84 KB, image/png)
2022-03-08 20:21 UTC, Gabor Kelemen (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kelemen (allotropia) 2022-03-08 20:19:35 UTC
Created attachment 178732 [details]
Example file from PP

Attached presentation has a master shape with the setting "Slide background fill", and the master slide layout has a background image set.

When opened in Impress the master shape has the master slide layouts background image set as a stretched background image.
In PP it set to No fill.

1, Open attached file
2, Observe that the "Click to add text" box in the middle has a background image fill, matching the master slides background.

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 7ac19fbce8a35f559eebb879cd0f232bfc95e703
CPU threads: 14; OS: Windows 10.0 Build 19044; UI render: default; VCL: win
Locale: en-US (hu_HU); UI: en-US
Calc: threaded Jumbo

Bibisected in 5.2 to:

https://git.libreoffice.org/core/+/f3d1ac75c4b7fa63022e54a9cbff46ba99535076%5E%21

author	Matus Uzak <matus.uzak@gmail.com>	Tue Mar 08 21:44:21 2016 +0100
committer	Katarina Behrens <Katarina.Behrens@cib.de>	Wed Mar 23 06:49:01 2016 +0000

tdf#93868: PPTX import: Incorrect inheritance of shape fill properties

Before this the background was white color fill.
This was differently bad, not setting regression.

This is similar to bug 128150, there the background is a gradient instead of an image.
Comment 1 Gabor Kelemen (allotropia) 2022-03-08 20:20:28 UTC
Created attachment 178733 [details]
The example file in PP 2013 and current master in Master slide view
Comment 2 Gabor Kelemen (allotropia) 2022-03-08 20:21:10 UTC
Created attachment 178734 [details]
The example file in PP 2013 and current master in slide edit view
Comment 3 Julien Nabet 2022-03-08 20:44:47 UTC
(In reply to Gabor Kelemen (allotropia) from comment #0)
> ...
> https://git.libreoffice.org/core/+/
> f3d1ac75c4b7fa63022e54a9cbff46ba99535076%5E%21
> 
> author	Matus Uzak <matus.uzak@gmail.com>	Tue Mar 08 21:44:21 2016 +0100
> committer	Katarina Behrens <Katarina.Behrens@cib.de>	Wed Mar 23 06:49:01
> 2016 +0000
> 
> tdf#93868: PPTX import: Incorrect inheritance of shape fill properties
> ...

Just for info, there's been https://cgit.freedesktop.org/libreoffice/core/commit/?id=554158f7d33742284905ed4953dd09041ea04a5d to fix some pb with the commit quoted.
Comment 4 Samuel Mehrbrodt (allotropia) 2022-06-20 12:44:40 UTC
Will be fixed with bug 128150.

*** This bug has been marked as a duplicate of bug 128150 ***