Bug 147888 - Only one option to choose when slide elements should appear
Summary: Only one option to choose when slide elements should appear
Status: RESOLVED DUPLICATE of bug 144585
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
7.3.1.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: KDE
  Show dependency treegraph
 
Reported: 2022-03-10 06:16 UTC by pieter kristensen
Modified: 2022-03-25 06:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
arrow points to problem (249.72 KB, image/jpeg)
2022-03-10 06:16 UTC, pieter kristensen
Details
Screenshot where it's OK (117.15 KB, image/png)
2022-03-23 07:14 UTC, Michael Weghorn
Details
Screencast (3.49 MB, video/x-matroska)
2022-03-23 15:28 UTC, Michael Weghorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pieter kristensen 2022-03-10 06:16:26 UTC
Created attachment 178768 [details]
arrow points to problem

I use KDE Neon Plasma User Edition. 
When I want to choose the way a selected element of the slide should appear, I have only one option.
There is no "with previous" or "after previous".
Strange thing is that on my Ubuntu machine, with the same version of LO, I càn choose those options
Comment 1 pieter kristensen 2022-03-17 18:38:37 UTC
I'm doing a little more testing...
With version 7.3.1.3 on my Plasma machine there is only one option to choose when selected slide elements can come in: "on click".
Version 6.4.7.2 gives me all three options to choose from on the same machine.
Comment 2 pieter kristensen 2022-03-19 13:20:07 UTC
Also the version 7.3.2.1 gives me only the option to bring in a selected element of the slide "on click". That's the only option too. On my plasma machine.
Comment 3 Michael Weghorn 2022-03-23 07:14:26 UTC
Created attachment 179046 [details]
Screenshot where it's OK
Comment 4 Michael Weghorn 2022-03-23 07:17:53 UTC
I can't reproduce here on Debian testing in a Plasma X11 session, s. attached screenshot attachment 179046 [details].

The desired options are the with both, git master and 7.3.1.3:

Version: 7.3.1.3 / LibreOffice Community
Build ID: a69ca51ded25f3eefd52d7bf9a5fad8c90b87951
CPU threads: 12; OS: Linux 5.16; UI render: default; VCL: kf5 (cairo+xcb)
Locale: en-GB (en_GB.UTF-8); UI: en-US
Calc: threaded

Is this in an X11 or a Wayland session? Can you paste the information from "Help" -> "About LibreOffice"? Also, does it work with a fresh user profile?

Did you install LibreOffice from your distro or download it from TDF website?
Comment 5 pieter kristensen 2022-03-23 13:31:32 UTC
in short:

The version Build ID: 1:6.4.7-0ubuntu0.20.04.4
behaves very well using X and using Wayland.

The version Version: 

7.3.2.1 / LibreOffice Community
Build ID: 0b2e59a88b7e225b655db87910f97dca7aef27aa
CPU threads: 4; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+wayland)
Locale: nl-NL (nl_NL.UTF-8); UI: en-US
Calc: threaded

behaves well using X and not ok using Wayland.

To be exact: 

first:
Operating System: KDE neon 5.24
KDE Plasma Version: 5.24.3
KDE Frameworks Version: 5.92.0
Qt Version: 5.15.3
Kernel Version: 5.13.0-37-generic (64-bit)
Graphics Platform: Wayland
Processors: 4 × Intel® Celeron® J4105 CPU @ 1.50GHz
Memory: 7.4 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 600

ALL with clean user profile

LO 
Version: 6.4.7.2
Build ID: 1:6.4.7-0ubuntu0.20.04.4
CPU threads: 4; OS: Linux 5.13; UI render: default; VCL: kf5; 
Locale: nl-NL (nl_NL.UTF-8); UI-Language: en-US
Calc: threaded

Wayland tabbed interface: ok
Wayland standard interface: ok

X tabbed interface: ok
X standard interface ok


Version: 7.3.2.1 / LibreOffice Community
Build ID: 0b2e59a88b7e225b655db87910f97dca7aef27aa
CPU threads: 4; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+wayland)
Locale: nl-NL (nl_NL.UTF-8); UI: en-US
Calc: threaded

Wayland tabbed interface: not ok
Wayland standard interface: not ok

X tabbed interface: ok
X standard interface: ok
Comment 6 Michael Weghorn 2022-03-23 15:28:25 UTC
Created attachment 179051 [details]
Screencast
Comment 7 Michael Weghorn 2022-03-23 15:30:13 UTC
Thanks for the detailed analysis! In my case, the popup with the different options (sometimes) shows up a for a very short amount of time, at a wrong location, s. screencast in attachment 179051 [details].

That's the issue described in tdf#144585; closing this bug as a duplicate of the latter.

*** This bug has been marked as a duplicate of bug 144585 ***
Comment 8 pieter kristensen 2022-03-24 17:02:12 UTC
A few moments ago I got on the same machine (comment 5) an update to the version below out of the libreoffice-ppa

Version: 7.2.6.2 / LibreOffice Community
Build ID: 20(Build:2)
CPU threads: 4; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+wayland)
Locale: nl-NL (nl_NL.UTF-8); UI: nl-NL
Ubuntu package version: 1:7.2.6-0ubuntu0.20.04.1~lo2
Calc: threaded

You won't believe this: this bug is gone!
Before I press "save changes" I will do some more testing...

No, I really believe it's gone...

Just to let you know.
Comment 9 Michael Weghorn 2022-03-25 06:24:19 UTC
(In reply to pieter kristensen from comment #8)
> A few moments ago I got on the same machine (comment 5) an update to the
> version below out of the libreoffice-ppa
> 
> Version: 7.2.6.2 / LibreOffice Community
> Build ID: 20(Build:2)
> CPU threads: 4; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+wayland)
> Locale: nl-NL (nl_NL.UTF-8); UI: nl-NL
> Ubuntu package version: 1:7.2.6-0ubuntu0.20.04.1~lo2
> Calc: threaded
> 
> You won't believe this: this bug is gone!

This is fixed in 7.2, but not 7.3 and later, see tdf#144585 comment 6.
Comment 10 pieter kristensen 2022-03-25 06:52:16 UTC
(In reply to Michael Weghorn from comment #9)
> (In reply to pieter kristensen from comment #8)
> > A few moments ago I got on the same machine (comment 5) an update to the
> > version below out of the libreoffice-ppa
> > 
> > Version: 7.2.6.2 / LibreOffice Community
> > Build ID: 20(Build:2)
> > CPU threads: 4; OS: Linux 5.13; UI render: default; VCL: kf5 (cairo+wayland)
> > Locale: nl-NL (nl_NL.UTF-8); UI: nl-NL
> > Ubuntu package version: 1:7.2.6-0ubuntu0.20.04.1~lo2
> > Calc: threaded
> > 
> > You won't believe this: this bug is gone!
> 
> This is fixed in 7.2, but not 7.3 and later, see tdf#144585 comment 6.

Thank you for your reaction. Apparently I didn't read carefully enough... Bummer...