Bug 147957 - Dropdowns not working on Wayland (across LibreOffice Products)
Summary: Dropdowns not working on Wayland (across LibreOffice Products)
Status: RESOLVED DUPLICATE of bug 144585
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
7.3.1.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-03-13 09:19 UTC by tomraus
Modified: 2022-03-13 09:35 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tomraus 2022-03-13 09:19:13 UTC
Description:
When working in any LibreOffice product, the drop downs are not working. This can either be a drop-down as part of LibreOffice Calc - Autofilter or LibreOffice Draw to change the font size or the type of object to be dragged on the page.

Steps to Reproduce:
1.Open Writer
2.Use drop-down to change font or fontsize
3.Drop-down doesn't appear

Actual Results:
Nothing happens, no dropdown. You can type and press enter which will take into account your requested change.

Expected Results:
Show a dropdown, with a scroller which allows me to select font size, font or other options.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
clicking multiple time on the drop down arrow, sometimes does show the intended window in the middle of my screen. However, it disappears so quickly that it cannot be used.

Disabling hardware acceleration in the LibreOffice options does not change outcome.


Version: 7.3.1.3 / LibreOffice Community
Build ID: 30(Build:3)
CPU threads: 16; OS: Linux 5.16; UI render: default; VCL: kf5 (cairo+wayland)
Locale: en-US (en_CH.UTF-8); UI: en-US
Calc: threaded
Comment 1 tomraus 2022-03-13 09:22:59 UTC
This does not happen under X11.
Comment 2 Buovjaga 2022-03-13 09:35:13 UTC

*** This bug has been marked as a duplicate of bug 144585 ***