Bug 147968 - Crash on file open (Win-only?) mergedlo!VirtualDevice::ImplInitVirDev+0x5d8
Summary: Crash on file open (Win-only?) mergedlo!VirtualDevice::ImplInitVirDev+0x5d8
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.4.0.0 alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: GDI-Limit Crash
  Show dependency treegraph
 
Reported: 2022-03-13 18:39 UTC by Telesto
Modified: 2022-03-14 08:22 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2022-03-13 18:39:10 UTC
Description:
Crash on file open (Win-only?)

Steps to Reproduce:
1. Open attachment 178591 [details]

Actual Results:
Crahes

Expected Results:
No crash


Reproducible: Always


User Profile Reset: No



Additional Info:
Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 3ccc4c123f5e78e0204d11abeab2d1a74278ca3e
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 1 Telesto 2022-03-13 18:41:36 UTC
BT looks the same as for bug 146976 but this one is easier to reproduce
Comment 2 Mike Kaganski 2022-03-13 22:13:15 UTC
This is 10000 GDI objects limit.
Comment 3 Mike Kaganski 2022-03-14 06:33:35 UTC
But why do you take a bug that is about crash opening a file, and create another bug about the crash opening that file? This is just bug 147708, nothing less, nothing more, - or do I miss something?
Comment 4 Mike Kaganski 2022-03-14 07:09:16 UTC
Resolving INVALID, as it can't be a dupe - dupes are created without knowing that there is such a problem reported already.
Comment 5 Telesto 2022-03-14 08:22:37 UTC
(In reply to Mike Kaganski from comment #3)
> But why do you take a bug that is about crash opening a file, and create
> another bug about the crash opening that file? This is just bug 147708,
> nothing less, nothing more, - or do I miss something?

Nope you didn't miss anything, this is exactly the same as bug 147708. 

Why this landed here..

I downloaded the file 1 march on my macbook. File didn't crash. 

8 days later I did notice an assert, bug 147964

Eventually I reported the assert.. 12 march or so. Copying bug file source from the browser download history.

Next I attempted to open the file on my Windows machine... crash.. without me realizing / recalling this being the reason of downloading the file the first place..

I could/should have checked before reporting..