Bug 148110 - Libre Office Base crashes on including Charts in Reports
Summary: Libre Office Base crashes on including Charts in Reports
Status: RESOLVED DUPLICATE of bug 117159
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
7.3.1.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL: https://crashreport.libreoffice.org/s...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-03-21 12:42 UTC by DanielMajlath
Modified: 2022-03-21 16:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DanielMajlath 2022-03-21 12:42:08 UTC
Description:
In my case LO Base Reports crashes every time a chart is inserted into it. After saveing my LO Base project on my second attempt to edit the report (more preciesly every time when i click on the chart) LO crashes and quits. How can I fix this problem, is there any solution? I really would like to have a chart diagram at the end of (last page) my report. Thank you!

Steps to Reproduce:
1.Create two tables
2.Create a Query from those two tables 
3.Create a report based on data in Query from step 2 (using Reoport Wizard)
4.Insert and format some type of chart into report from step 3 and save it
5.Quit from report created in previous steps and open it again in edit mode
6.Click on or select the Chart in report (that should produce the crash mentioned)

Actual Results:
Unsuspected crash

Expected Results:
A Report of executed Tasks Grouped by my co-workers and sorted by date of execution including a Chart with the number of tasks by they type (predefined types of tasks like: terain measurements, Software upgrades, Installation, Others etc.)


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
Tested with LO 7.3.1 and LO 7.2.6 on Windows 7 and Windows 10 
on so called Embedded database: HSQLDB Embedded

Version: 7.3.1.3 (x64) / LibreOffice Community
Build ID: a69ca51ded25f3eefd52d7bf9a5fad8c90b87951
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: sr-Latn-RS (sr_RS); UI: en-US
Calc: CL
Comment 1 Mike Kaganski 2022-03-21 14:30:17 UTC

*** This bug has been marked as a duplicate of bug 117159 ***
Comment 2 Robert Großkopf 2022-03-21 14:39:06 UTC
Opened a report and created a chart in the report. No problem here with OpenSUSE 15.3 64bit rpm Linux / LO 7.3.1.3.

But please have a look at bug 117162 : Charts aren't shown in reports since LO 5.4.
Comment 3 Robert Großkopf 2022-03-21 14:41:26 UTC
(In reply to Mike Kaganski from comment #1)
> 
> *** This bug has been marked as a duplicate of bug 117159 ***

This isn't a duplicate of bug 117159.
Bug 117159 is a bout the possibility to edit a specific chart (or delete it), not about creating a new chart. This bug here is about including a chart in a report.
Comment 4 Mike Kaganski 2022-03-21 14:42:17 UTC
(In reply to Robert Großkopf from comment #2)

Why did you revert my edits (marking it as duplicate of your bug)?
Do you use the "workaround" mentioned in bug 117159 comment 13, which makes your LO to survive the selection?
Comment 5 Mike Kaganski 2022-03-21 14:43:16 UTC
(In reply to Robert Großkopf from comment #3)

Please re-resd the description. Re-read it again. Then imagine that I even debugged the problem here before marking it duplicate.
Comment 6 Robert Großkopf 2022-03-21 16:14:35 UTC
(In reply to Mike Kaganski from comment #5)
> (In reply to Robert Großkopf from comment #3)
> 
> Please re-resd the description. Re-read it again. Then imagine that I even
> debugged the problem here before marking it duplicate.

You are right!

Have read the title about "including charts" and can't confirm that it produces a crash. But the description is about editing an existing chart.

*** This bug has been marked as a duplicate of bug 117159 ***