Bug 148111 - FILEOPEN: DOCX: Text Field is empty
Summary: FILEOPEN: DOCX: Text Field is empty
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.4.0.0 alpha0+
Hardware: All All
: high major
Assignee: Vasily Melenchuk (CIB)
URL:
Whiteboard: target:7.4.0 target:7.3.3
Keywords: bibisected, bisected, regression
Depends on:
Blocks: DOCX-Content_Control
  Show dependency treegraph
 
Reported: 2022-03-21 12:57 UTC by Xisco Faulí
Modified: 2022-05-23 09:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Comparison MSO 2010 and LibreOffice 7.4 master (18.11 KB, image/png)
2022-03-21 12:57 UTC, Xisco Faulí
Details
another file affected (59.95 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2022-03-21 15:51 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Xisco Faulí 2022-03-21 12:57:20 UTC
Created attachment 179005 [details]
Comparison MSO 2010 and LibreOffice 7.4 master

Steps to reproduce it:
1. Open attachment 53019 [details] from bug 42486

-> Second field should have the text "[Tippige dokumendi alapealkiri]". See comparison image.


Reproduced in

Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: cfd82e7a2cc2b45b738eb0efa0827196d2de61a4
CPU threads: 8; OS: Linux 5.10; UI render: default; VCL: gtk3
Locale: es-ES (es_ES.UTF-8); UI: en-US
Calc: threaded

[Bug found by office-interoperability-tools]
Comment 1 Xisco Faulí 2022-03-21 12:58:29 UTC
Regression introduced by:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=b5c616d10bff3213840d4893d13b4493de71fa56

author	Vasily Melenchuk <vasily.melenchuk@cib.de>	2021-11-24 14:50:12 +0300
committer	Thorsten Behrens <thorsten.behrens@allotropia.de>	2021-12-20 00:16:12 +0100
commit b5c616d10bff3213840d4893d13b4493de71fa56 (patch)
tree d96535ffae96f4b0c35aee51a3257770826c8063
parent 302ef0c63b8e95d040cf5b19865e8540e78f9d15 (diff)
tdf#104823: support for sdt plain text fields

Bisected with: bibisect-linux64-7.4

Adding Cc: to Vasily Melenchuk
Comment 2 Xisco Faulí 2022-03-21 13:14:39 UTC
Also reproduced with attachment from bug 61580 from bug 49881
Comment 3 Xisco Faulí 2022-03-21 13:19:46 UTC
and attachment 74270 [details] from bug 60351
Comment 4 Xisco Faulí 2022-03-21 15:51:10 UTC
Created attachment 179011 [details]
another file affected
Comment 5 Commit Notification 2022-03-26 22:02:44 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9d033508af5257aeebbd8c22a053db5e74a814d3

tdf#148111: docx std fields: use placeholder text for empty data

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Vasily Melenchuk (CIB) 2022-03-27 05:29:07 UTC
Patch from comment#5 resolves problem: testcase document std fields right now look better, as before introduction of sdt fields.

But overall behavior for placeholder replacement is more complicated: it depends on <w:showingPlcHdr> parameter which currently not supported in LO. This parameter requires handling and correct roundtrip on load/save in LO. 

See testcase sw\qa\extras\ooxmlexport\data\tdf148111.docx 

So bug is still unresolved.
Comment 7 Commit Notification 2022-03-28 09:33:05 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/cebca5086b42ff9462d8c6f8ed2344a0138b2f4a

tdf#148111: docx std fields: use placeholder text for empty data

It will be available in 7.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Vasily Melenchuk (CIB) 2022-05-23 09:02:57 UTC
Since regression is fixed, I'm closing this issue.
Further improvements proposals are extracted to tdf#149240.