Bug 148202 - Inopportune combination of selection effect and area color in styles dialog
Summary: Inopportune combination of selection effect and area color in styles dialog
Status: RESOLVED DUPLICATE of bug 115507
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.4.0.0 alpha0+
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar-Styles
  Show dependency treegraph
 
Reported: 2022-03-26 09:22 UTC by Eyal Rozenberg
Modified: 2022-03-30 07:41 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot with and without area set to white (89.87 KB, image/png)
2022-03-26 09:22 UTC, Eyal Rozenberg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eyal Rozenberg 2022-03-26 09:22:35 UTC
Created attachment 179119 [details]
Screenshot with and without area set to white

When you select a style on the sidebar, its background becomes Dark Blue and its name becomes White (well, in a typical desktop environment color scheme and not in "dark mode").

However, if you the set that paragraph style to have a light area color, say White, the area color does show, while the paragraph text remains White, as in a regular selected style. The result is a White-on-White item.
Comment 1 Heiko Tietze 2022-03-30 07:41:56 UTC
See also bug 137705 for dark themes. In a nutshell, the background of the Stylist should use the document background color and font color (accepting that in case both are white you wont see anything) and my first approach failed since the only Stylist tree took the color not the whole sidebar deck.

*** This bug has been marked as a duplicate of bug 115507 ***