Bug 148424 - Border color of active, focused cell is hard to see on Ubuntu
Summary: Border color of active, focused cell is hard to see on Ubuntu
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.3.2.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Rafael Lima
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Selection
  Show dependency treegraph
 
Reported: 2022-04-06 12:35 UTC by fazliddin.uzbek
Modified: 2022-05-27 19:18 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot showing the new cell focus rectangle in LO 7.4 (7.56 KB, image/png)
2022-05-27 19:18 UTC, Rafael Lima
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fazliddin.uzbek 2022-04-06 12:35:35 UTC
Border color of active, focused cell is hard to see. Especially it is hard when cells have border color. It was good in ubuntu 18.04
Comment 1 stragu 2022-04-13 00:46:24 UTC Comment hidden (obsolete)
Comment 2 stragu 2022-04-13 00:49:57 UTC
Hi Fazliddin
Thanks for the report.

Could you please:
- Copy and paste the "Help > About" information in your affected version
- Include a screenshot of the issue as an attachment here
- Give us the version of LibreOffice used in Ubuntu 18.04, if you have it.

I assume this is because of the fix for Bug 142121, now using the system colour for the selection/cursor.

For me, on Ubuntu 20.04 with LO 7.3.2.2, the cursor is very evident with the default orange colour in dark mode.

Here are some related bugs:
- About improving the contrast, but macOS-specific: Bug 145080
- About making the border more obvious and placed more optimally, with a (partial?) fix in the 7.4 branch: Bug 143733

Added meta bug, see also bugs, and used more precise summary.
Comment 3 Rafael Lima 2022-05-27 19:18:04 UTC
Created attachment 180438 [details]
Screenshot showing the new cell focus rectangle in LO 7.4

Since LO 7.3 the cell focus rectangle uses system highlight color. And in LO 7.4 the cell rectangle is a thicker and more visible.

See attached image for more info.

I'm closing this as WFM.