Bug 148429 - Link external data doesn't work anymore due to web server not permitting "curl" user agent
Summary: Link external data doesn't work anymore due to web server not permitting "cur...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.3.2.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.4.0 target:7.3.4 target:7.3.3
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Calc-External-Datalink WebDAV
  Show dependency treegraph
 
Reported: 2022-04-06 18:06 UTC by Cleber Santz
Modified: 2022-04-26 08:41 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cleber Santz 2022-04-06 18:06:11 UTC
After upgrading to LibreOffice 7.3 my external data links does not update anymore.

Some links are still updated, but some links like this one doesn't work anymore URL: https://fundamentus.com.br/fii_resultado.php

Even if I create a new File and go to Link External Data it brings nothing for the URL: https://fundamentus.com.br/fii_resultado.php
Comment 1 Andreas Heinisch 2022-04-08 13:12:32 UTC
Confirmed in:
Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: d84e6bbe5d34c78a4a8be1fbc532067d83f8eac9
CPU threads: 4; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: en-US
Calc: CL

Works in:
Version: 6.3.0.0.beta1 (x64)
Build-ID: a187af327633f5f00363be5131bd21a13e0f1a7b
CPU-Threads: 4; BS: Windows 10.0; UI-Render: Standard; VCL: win; 
Gebietsschema: en-US (de_DE); UI-Sprache: de-DE
Calc: CL
Comment 2 raal 2022-04-08 22:13:42 UTC
This seems to have begun at the below commit.
Adding Cc: to Michael Stahl; Could you possibly take a look at this one?
Thanks
 115b11fc60754321653e4f44d88d1b033163c3da is the first bad commit
commit 115b11fc60754321653e4f44d88d1b033163c3da
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Tue Nov 23 20:19:31 2021 +0100

    source sha:bdef11f5337ecc87556a92693f6b7b5e200eb29e

https://git.libreoffice.org/core/+/bdef11f5337ecc87556a92693f6b7b5e200eb29e
  configure: default to --with-webdav=curl
Comment 3 Cleber Santz 2022-04-11 18:26:59 UTC
Testing access the URL directly with curl returns "Access denied", probably because a User agent whitelist:

#curl https://fundamentus.com.br/fii_resultado.php 

The command above returns "Access denied", but with command below returns webpage with success:

#curl --user-agent 'Chrome/90' https://fundamentus.com.br/fii_resultado.php

Is there any option to set the User agent to curl in Libreoffice ? Or is possible to set a default user agent in Libreoffice builds ?
Comment 4 Commit Notification 2022-04-20 13:48:51 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/8d9c56e8f42428fd6695942c673bffb985d22ad5

tdf#146460 tdf#148429 ucb: webdav-curl: censor "curl" in UserAgent

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Michael Stahl (allotropia) 2022-04-20 17:10:52 UTC
argh, the web is terrible!
Comment 6 Commit Notification 2022-04-21 12:16:53 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/3fe6a03426a86ec6b18a9b712588619f19a72897

tdf#146460 tdf#148429 ucb: webdav-curl: censor "curl" in UserAgent

It will be available in 7.3.4.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2022-04-26 08:41:49 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-7-3-3":

https://git.libreoffice.org/core/commit/6147f454d5827dd60a926c9ee504a61d4f0cd3e4

tdf#146460 tdf#148429 ucb: webdav-curl: censor "curl" in UserAgent

It will be available in 7.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.