Bug 148538 - Freeze First Column/Row only works when the first column/row is visible on the screen
Summary: Freeze First Column/Row only works when the first column/row is visible on th...
Status: RESOLVED DUPLICATE of bug 112641
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.3.1.3 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-04-12 14:44 UTC by daniel.schaaaf
Modified: 2022-07-20 02:47 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description daniel.schaaaf 2022-04-12 14:44:46 UTC
Description:
"Freeze First Column/Row", in the drop down menu of the "Freeze Rows and Columns" button, only works when the first column/row is visible on the screen.

Intuitively, this function only makes sense when the first column/row is _not_ visible on the screen. In that case, it would provide a shortcut to freeze the first column/row.

When the first column/row is visible, the user can mark it and click the "Freeze Rows and Columns" button. In that case, "Freeze First Column/Row" does not provide any benefit.

The way the "Freeze First Column/Row" works currently renders this function useless.

Steps to Reproduce:
1. In a spreadsheet, scroll down and right until A1 is off screen.
2. Click on "Freeze First Column/Row".

Actual Results:
After clicking on "Freeze First Column/Row", nothing happens.

Expected Results:
The first column/row should be frozen.


Reproducible: Always


User Profile Reset: Yes


OpenGL enabled: Yes

Additional Info:
[Information automatically included from LibreOffice]
Locale: en-GB
Module: SpreadsheetDocument
[Information guessed from browser]
OS: Windows (All)
OS is 64bit: no
Comment 1 giger.jonathan 2022-04-13 22:29:16 UTC
I can confirm this happens when using the  View > Freeze Cells > Freeze First Column or Freeze First Row option. The View > Freeze Rows and Columns option works fine.

Version: 7.2.6.2 (x64) / LibreOffice Community
Build ID: b0ec3a565991f7569a5a7f5d24fed7f52653d754
CPU threads: 12; OS: Windows 10.0 Build 19044; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL
Comment 2 Aron Budea 2022-06-04 07:01:40 UTC
This is a duplicate of bug 100666.

*** This bug has been marked as a duplicate of bug 100666 ***
Comment 3 Aron Budea 2022-07-20 02:47:14 UTC

*** This bug has been marked as a duplicate of bug 112641 ***