Bug 148562 - Popup menu on wayland instantly closes after being opened
Summary: Popup menu on wayland instantly closes after being opened
Status: RESOLVED DUPLICATE of bug 144585
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
7.3.1.3 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Wayland KDE
  Show dependency treegraph
 
Reported: 2022-04-13 12:09 UTC by hasezoey
Modified: 2022-04-14 04:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hasezoey 2022-04-13 12:09:15 UTC
Description:
When trying to open a popup (for example font selection), the menu for the fonts briefly shows, but then instantly closes

Note menus from the toolbar just work without problems (like the ones from the drop-down menus for "File, Edit, View, Insert, etc...", only popup menus for things like "Font selection or Style selection" are affected

I have also tested on another machine (with a similar install and same libreoffice version), where the popup does not even show briefly

Steps to Reproduce:
0. have a system with wayland (in my case kde-plasma)
1. open Libreoffice Writer (with a document)
2. try to change the font with the popup menu by clicking on the "down arrow"
3. observe output

Actual Results:
Popup window instantly closes before being able to choose a font

Expected Results:
Popup window should stay open until having selected a font


Reproducible: Always


User Profile Reset: Yes



Additional Info:
Version: 7.3.1.3 / LibreOffice Community
Build ID: 30(Build:3)
CPU threads: 8; OS: Linux 5.16; UI render: default; VCL: kf5 (cairo+wayland)
Locale: de-DE (en_US.UTF-8); UI: en-US
7.3.1-1
Calc: threaded

i could not find a option for "OpenGL", though for "Graphics Output" "Use hardware acceleration" is enabled, and "Run Graphics Tests" passes 1 test and skips all others, but it still happens when "Use hardware acceleration" is disabled"

(OpenCL is disabled)

a video showcasing the problem: https://youtu.be/fXDVH1vdyS0
the video shows at first that the toolbar menu is working, then that the font selection popup and style selection popup instantly close

i have also tried the following version (name: "LibreOfficeDev-7.4.0.0.alpha0_2022-01-23-x86_64.AppImage":
Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: 465c3ad95059f0efa13c8027f7383c4d20a5b2ff
CPU threads: 8; OS: Linux 5.16; UI render: default; VCL: kf5 (cairo+wayland)
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

and the issue still exists
Comment 1 Michael Weghorn 2022-04-14 04:55:50 UTC
That has been fixed recently, s. tdf#144585.

*** This bug has been marked as a duplicate of bug 144585 ***