Bug 148584 - Libre is taking so much time while opening and converting 7188 pages DOCX > 10mb
Summary: Libre is taking so much time while opening and converting 7188 pages DOCX > 10mb
Status: RESOLVED DUPLICATE of bug 144501
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
7.2.5.2 release
Hardware: All Windows (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx, perf
Depends on:
Blocks: DOCX-Opening
  Show dependency treegraph
 
Reported: 2022-04-14 07:33 UTC by Vikas
Modified: 2022-04-26 14:20 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
this is the actual file which is taking more time. (10.64 MB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2022-04-14 07:34 UTC, Vikas
Details
The file with images and gets converted into PDF quickly. (11.34 MB, application/msword)
2022-04-14 07:36 UTC, Vikas
Details
One more .docx file (6.15 MB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2022-04-20 16:03 UTC, Vikas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vikas 2022-04-14 07:33:43 UTC
Description:
I have one .docx file with a file size >10MB (with content). When I am trying to convert it to PDF using the below command takes so much time.

If I upload a file that contains images and the size is >10 MB, works fine.

soffice.com --headless --convert-to pdf D:\InputFiles\word2pdf\TestSpecification_upd.docx --outdir D:\InputFiles\word2pdf

Steps to Reproduce:
1.Run given command with the attached file to reproduce the issue.
2.Then try the same command with another file that has images as content works fine.
3.

Actual Results:
The file is taking a longer time than expected.

Expected Results:
It should not take more than sec to translate such big files.


Reproducible: Always


User Profile Reset: No



Additional Info:
NA
Comment 1 Vikas 2022-04-14 07:34:36 UTC
Created attachment 179547 [details]
this is the actual file which is taking more time.
Comment 2 Vikas 2022-04-14 07:36:50 UTC
Created attachment 179548 [details]
The file with images and gets converted into PDF quickly.
Comment 3 Telesto 2022-04-15 07:57:24 UTC
Opening TestSpecification_upd.docx is very slow (or fails, didn't wait long enough) with
Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: efe854bf9b6daff3d0ecf6e3d04bd9a50bfaa3f3
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL Jumbo

and in with
7.2

and in with
4.4.7.2

and with
3.5.7.2

Word 2003 does open it eventually and Word Online doesn't like the file either.
Comment 4 Vikas 2022-04-20 16:02:26 UTC
Actually, it does open with v7.2.5.2 but takes so much time to open and for conversion also had to wait for more than 20 mins.

I am attaching one more file which took more time to translate.
Comment 5 Vikas 2022-04-20 16:03:22 UTC
Created attachment 179686 [details]
One more .docx file
Comment 6 Michael Warner 2022-04-23 15:38:32 UTC
As another data point of comparison, Apple Pages on a MacBook M1 spent over 1 hour 45 minutes chewing on it (at 100% of a CPU core) and still hadn't finished opening it when I decided to just kill it. 

So, whatever is in this file, it causes problems for everything.
Comment 7 Michael Warner 2022-04-23 15:39:58 UTC
Based on Telesto's confirmation in Comment 3, I am setting status to NEW.
Comment 8 Vikas 2022-04-26 12:18:45 UTC Comment hidden (no-value)
Comment 9 Timur 2022-04-26 14:06:06 UTC
(In reply to Vikas from comment #8)
> Hi All,
> 
> Any update on this bug? will there be any fix for this?

Yes. If you do it yourself, find or pay someone do it. 
If not, do not spam. There are bugs open for 10 years.
Comment 10 Timur 2022-04-26 14:20:07 UTC
When report starts with "I" it usually is not proper. 
7188 pages.
In this case, probably a duplicate.

*** This bug has been marked as a duplicate of bug 144501 ***