Bug 148590 - Editing: Formulas pasted as numbers between different versions of Calc
Summary: Editing: Formulas pasted as numbers between different versions of Calc
Status: RESOLVED DUPLICATE of bug 124006
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2022-04-14 11:34 UTC by Alistair Saywell
Modified: 2022-06-04 22:15 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alistair Saywell 2022-04-14 11:34:06 UTC
If I copy from spreadsheet in Calc 7.2.5.2 and paste to Calc 7.3.1.3 in same computer, the formulas are converted to numbers. If I select Paste Formulas then nothing is pasted. Have tried every type in Paste Special. 

Same pasting of numbers-only (not formula) to Excel 2010 & Excel 2019, even selecting SLYK. The reverse direction, from Excel to Calc pastes formula

Possibly related to https://bugs.documentfoundation.org/show_bug.cgi?id=31077#c27

Example:
In 7.2.5.2 I create spreadsheet, I enter in A1 1, A2 2, A3 =A1+A2
I copy all three cells and paste into a new spreadsheet in Calc 7.3.1.3. 
I get A1 1, A2 2, A3 3. No formula

Expected result: Formula is pasted
Actual result: Number only pasted
Reproducible: Always. 

Tested on two Windows 11 computers (other 7.2.6.2 to 7.3.2.2 and reverse) with same results. New user profile, Windows clipboard manager on or off.

Most recent test on:
Version: 7.2.5.2 (x64) / LibreOffice Community
Build ID: 499f9727c189e6ef3471021d6132d4c694f357e5
CPU threads: 8; OS: Windows 10.0 Build 22000; UI render: Skia/Raster; VCL: win
Locale: en-NZ (en_NZ); UI: en-GB
Calc: threaded

Version: 7.3.1.3 (x64) / LibreOffice Community
Build ID: a69ca51ded25f3eefd52d7bf9a5fad8c90b87951
CPU threads: 8; OS: Windows 10.0 Build 22000; UI render: default; VCL: win
Locale: en-NZ (en_NZ); UI: en-GB
Calc: threaded
Comment 1 Eike Rathke 2022-04-14 12:00:37 UTC
Can't reproduce on Linux, Gnome, formulas paste fine.
Comment 2 Aron Budea 2022-06-04 22:15:52 UTC
I'd say this is a duplicate of bug 124006.

*** This bug has been marked as a duplicate of bug 124006 ***