Bug 148624 - Crash in: GrVkPipelineState::setAndBindInputAttachment(GrVkGpu *,gr_sp<GrVkDescriptorSet const ,GrManagedResource,GrRecycledResource,{GrManagedResource::ref(void),0},{GrRecycledResource::recycle(void),0}>,GrVkCommandBuffer *)
Summary: Crash in: GrVkPipelineState::setAndBindInputAttachment(GrVkGpu *,gr_sp<GrVkDe...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
7.3.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.5.0 target:7.3.5 target:7.4....
Keywords:
Depends on:
Blocks: Skia
  Show dependency treegraph
 
Reported: 2022-04-16 17:07 UTC by Tex2002ans
Modified: 2022-06-19 20:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature: ["GrVkPipelineState::setAndBindInputAttachment(GrVkGpu *,gr_sp<GrVkDescriptorSet const ,GrManagedResource,GrRecycledResource,{GrManagedResource::ref(void),0},{GrRecycledResource::recycle(void),0}>,GrVkCommandBuffer *)"]
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tex2002ans 2022-04-16 17:07:24 UTC
This bug was filed from the crash reporting server and is br-853ade4b-9770-4cbe-9a65-b3af61356690.
=========================================

All I did was:

- Open a new document in Calc
- Clicked in a cell
- Insert > Chart
- Crash

I tried again, but couldn't reproduce crash. Completely random.
Comment 1 Julien Nabet 2022-04-16 22:01:15 UTC
Logs show "Skia", perhaps https://wiki.documentfoundation.org/QA/FirstSteps#Graphics-related_issues_.28_Skia_.29 may help.
Comment 2 Xisco Faulí 2022-04-18 11:32:59 UTC
@Lubos, I thought you might be interested in this issue
Comment 4 Commit Notification 2022-06-17 12:24:06 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/4dab8afe89c57318cc7503ae051963de89a6cd25

upstream Skia fix for Vulkan crash on texture binding (tdf#148624)

It will be available in 7.5.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2022-06-19 20:03:45 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/5704c346eac79f211f0487e369c0020c0595e1d8

upstream Skia fix for Vulkan crash on texture binding (tdf#148624)

It will be available in 7.3.5.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2022-06-19 20:04:00 UTC
Luboš Luňák committed a patch related to this issue.
It has been pushed to "libreoffice-7-4":

https://git.libreoffice.org/core/commit/30687f36f935381b30e463702fad9963377c25d3

upstream Skia fix for Vulkan crash on texture binding (tdf#148624)

It will be available in 7.4.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.